View Issue Details

IDProjectCategoryView StatusLast Update
0033384FPCCompilerpublic2019-07-13 09:16
ReporterSvetozar BelicAssigned ToSven Barth 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version3.3.1 
Summary0033384: Attributes support
DescriptionThe provided patches add support for attributes on class types and properties. It is based on work by Joost van der Sluis.

The unified diff against the current trunk can be seen at :
https://github.com/graemeg/freepascal/compare/master...transmogrifix:master

Any suggestions are welcome.

TagsNo tags attached.
Fixed in Revision42356-42411
FPCOldBugId
FPCTarget-
Attached Files

Activities

Svetozar Belic

2018-03-08 15:13

reporter  

attributes_patches.zip (49,394 bytes)

Svetozar Belic

2018-06-22 18:19

reporter   ~0109006

Last edited: 2018-06-22 18:24

View 3 revisions

Hi,

I have submitted this patch because I wanted to help out and didn't expect much, but it has been several months now with no response whatsoever. This makes me wonder if my code has some serious flaws?
I would appreciate at least some kind of feedback if possible.

Also, there are probably conflicts by now, if needed I can attach an up to date patch.

Thank you.

silvioprog

2018-11-03 22:13

reporter   ~0111763

@Svetozar: Great job! I'm monitoring this issue because I'm also interested in this feature.

Sven Barth

2019-07-13 00:09

manager   ~0117234

It took a while, but I've now managed to review and rework the attributes features. The only part I've not kept is the one for the type listing, cause that will be solved a bit differently with dynamic packages support.

Please test and close if okay.

Issue History

Date Modified Username Field Change
2018-03-08 15:13 Svetozar Belic New Issue
2018-03-08 15:13 Svetozar Belic File Added: attributes_patches.zip
2018-03-17 01:06 Michael Van Canneyt Assigned To => Sven Barth
2018-03-17 01:06 Michael Van Canneyt Status new => assigned
2018-06-22 18:19 Svetozar Belic Note Added: 0109006
2018-06-22 18:22 Svetozar Belic Note Edited: 0109006 View Revisions
2018-06-22 18:24 Svetozar Belic Note Edited: 0109006 View Revisions
2018-11-03 22:13 silvioprog Note Added: 0111763
2019-07-13 00:09 Sven Barth Status assigned => resolved
2019-07-13 00:09 Sven Barth Resolution open => fixed
2019-07-13 00:09 Sven Barth Fixed in Version => 3.3.1
2019-07-13 00:09 Sven Barth Fixed in Revision => 42356-42411
2019-07-13 00:09 Sven Barth FPCTarget => -
2019-07-13 00:09 Sven Barth Note Added: 0117234