View Issue Details

IDProjectCategoryView StatusLast Update
0033385FPCPackagespublic2018-03-19 09:52
ReporterStephanoAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.1.1Product Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0033385: fpreport: moHideZeros and moSuppressRepeated don't have any effect
Description- Create a report with a memo with moHideZeros or moSuppressRepeated set
- Create a float variable with a zero value and set the memo text accordingly
- Preview the report
The memo will still show the zero in all lines
TagsNo tags attached.
Fixed in Revision38563
FPCOldBugId0
FPCTarget
Attached Files

Activities

Michael Van Canneyt

2018-03-18 13:19

administrator   ~0107236

Fixed, thanks for reporting

Stephano

2018-03-18 18:50

developer   ~0107245

Bug resolved.
I reopened just to check one fringe behavior: strings are hidden if moHideZeros is set. Is that as designed?

Michael Van Canneyt

2018-03-19 09:04

administrator   ~0107251

I tried that here, they are correctly shown.
If you have a report that reproduces the behaviour with strings, please file a separate bug.

Stephano

2018-03-19 09:52

developer   ~0107258

I can't reproduce it now, and I never bothered to save an example report as I thought it would be easily reproducible.
I will file a bug report if i ever encounter this behavior again.

Issue History

Date Modified Username Field Change
2018-03-08 15:50 Stephano New Issue
2018-03-08 15:50 Stephano Status new => assigned
2018-03-08 15:50 Stephano Assigned To => Michael Van Canneyt
2018-03-08 19:57 Stephano Summary fpreport: moHideZeros doesn't have any effect => fpreport: moHideZeros and moSuppressRepeated don't have any effect
2018-03-08 19:57 Stephano Description Updated View Revisions
2018-03-18 13:19 Michael Van Canneyt Fixed in Revision => 38563
2018-03-18 13:19 Michael Van Canneyt Note Added: 0107236
2018-03-18 13:19 Michael Van Canneyt Status assigned => resolved
2018-03-18 13:19 Michael Van Canneyt Fixed in Version => 3.1.1
2018-03-18 13:19 Michael Van Canneyt Resolution open => fixed
2018-03-18 13:19 Michael Van Canneyt Target Version => 3.2.0
2018-03-18 18:50 Stephano Note Added: 0107245
2018-03-18 18:50 Stephano Status resolved => feedback
2018-03-18 18:50 Stephano Resolution fixed => reopened
2018-03-19 09:04 Michael Van Canneyt Note Added: 0107251
2018-03-19 09:04 Michael Van Canneyt Status feedback => resolved
2018-03-19 09:04 Michael Van Canneyt Resolution reopened => fixed
2018-03-19 09:52 Stephano Note Added: 0107258
2018-03-19 09:52 Stephano Status resolved => closed