View Issue Details

IDProjectCategoryView StatusLast Update
0033392FPCPackagespublic2018-03-15 10:11
ReporterStephanoAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.1.1Product Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0033392: fpreport (feature request): Add rfkCurrency variable type
DescriptionCurrency type is a must for financial applications, especially when aggregates like SUM are concerned.
TagsNo tags attached.
Fixed in Revision38527
FPCOldBugId0
FPCTarget
Attached Files

Activities

Michael Van Canneyt

2018-03-09 10:00

administrator   ~0107033

This would require adding currency type to the expression parser.
Not an easy task since it also means conversions etc etc etc.

Stephano

2018-03-09 10:04

developer   ~0107034

True, but it is a must for financial reporting tools. You can't risk having an end of report sum that differs from the actual sum even by 1 cent.
Think credit card, bank account statement, or even your local grocery invoice :)

Anyway, pls keep it in mind.

Michael Van Canneyt

2018-03-15 09:57

administrator   ~0107125

Implemented. Also implemented support for this type in the variables editor

Issue History

Date Modified Username Field Change
2018-03-09 07:43 Stephano New Issue
2018-03-09 07:43 Stephano Status new => assigned
2018-03-09 07:43 Stephano Assigned To => Michael Van Canneyt
2018-03-09 10:00 Michael Van Canneyt Note Added: 0107033
2018-03-09 10:04 Stephano Note Added: 0107034
2018-03-15 09:57 Michael Van Canneyt Fixed in Revision => 38527
2018-03-15 09:57 Michael Van Canneyt Note Added: 0107125
2018-03-15 09:57 Michael Van Canneyt Status assigned => resolved
2018-03-15 09:57 Michael Van Canneyt Fixed in Version => 3.1.1
2018-03-15 09:57 Michael Van Canneyt Resolution open => fixed
2018-03-15 09:57 Michael Van Canneyt Target Version => 3.2.0
2018-03-15 10:11 Stephano Status resolved => closed