View Issue Details

IDProjectCategoryView StatusLast Update
0033466FPCDocumentationpublic2018-03-23 23:10
ReporterZoran VučenovićAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionProduct Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0033466: Outdated documentation for unit typinfo
DescriptionI noticed two things which should be corrected on this page:
https://www.freepascal.org/docs-html/current/rtl/typinfo/index.html

1.
"The unit should be compatible to the Delphi 5 unit with the same name. The only calls that are still missing are the Variant calls, since Free Pascal does not support the variant type yet."

Free Pascal does not support the variant type? How old is this information?

2.
At the beginning of the text, just below "Overview":
"The TypeInfo unit..." (notice the e in TypeInfo, should be corrected to TypInfo).
TagsNo tags attached.
Fixed in Revision1475
FPCOldBugId
FPCTarget
Attached Files

Activities

Michael Van Canneyt

2018-03-23 23:10

administrator   ~0107380

Corrected, thanks for reporting !

Issue History

Date Modified Username Field Change
2018-03-20 15:16 Zoran Vučenović New Issue
2018-03-20 15:16 Zoran Vučenović Status new => assigned
2018-03-20 15:16 Zoran Vučenović Assigned To => Michael Van Canneyt
2018-03-23 23:10 Michael Van Canneyt Fixed in Revision => 1475
2018-03-23 23:10 Michael Van Canneyt Note Added: 0107380
2018-03-23 23:10 Michael Van Canneyt Status assigned => resolved
2018-03-23 23:10 Michael Van Canneyt Fixed in Version => 3.1.1
2018-03-23 23:10 Michael Van Canneyt Resolution open => fixed
2018-03-23 23:10 Michael Van Canneyt Target Version => 3.2.0