View Issue Details

IDProjectCategoryView StatusLast Update
0033484LazarusPackagespublic2018-03-23 11:27
ReporterStephanoAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.9 (SVN)Product Build 
Target VersionFixed in Version1.9 (SVN) 
Summary0033484: FPReport designer: Adding a page leads to a SIGSEGV
Description- Create a new report
- Add a report title band and a memo
- Add a page
The page will be page3 instead of page2
- Click on new report
The discard changes dialog will popup and a SIGSEGV will occur.
TagsNo tags attached.
Fixed in Revision57558
LazTarget-
Widgetset
Attached Files

Activities

Michael Van Canneyt

2018-03-23 08:39

administrator   ~0107356

I cannot reproduce this.

The fact that the second page is called page3 points to the fact that there is still a dangling page somewhere, maybe a residue of a previous attempt ?

Stephano

2018-03-23 10:46

developer   ~0107360

Make sure you follow the exact steps to reproduce the case. I can reproduce it consistently, starting from a fresh run.
Note that the report structure shows page3 while the tab on top shows page2.
I tracked the SIGSEGV to procedure TFPReportDesignerForm.StopDesigning:
  While PCReport.ControlCount>0 do
    PCReport.Controls[PCReport.ControlCount-1].Free; <- SIGSEGV

Michael Van Canneyt

2018-03-23 10:53

administrator   ~0107361

I did follow the exact steps.

Stephano

2018-03-23 11:02

developer   ~0107362

That's odd!
Does the report structure show page2 as well?
Did you click on the create new report toolbutton at the end, or exit designer? The latter doesn't give an error.

Stephano

2018-03-23 11:09

developer   ~0107364

Notes:
- The new page # jumps by the number of memos, checkboxes, images, and shapeboxes. so if i add 5 report elements, the new page number increases by 1+5.
- Pages have no name in the designer's OI.

Michael Van Canneyt

2018-03-23 11:14

administrator   ~0107366

I can reproduce it.
It only occurs when the newly added page is the active page.
You then get a onpagechange event which should not happen.

Michael Van Canneyt

2018-03-23 11:20

administrator   ~0107368

Fixed the AV.

The name of page is still displayed as 3, but that's something for a different bug report.

Issue History

Date Modified Username Field Change
2018-03-22 22:35 Stephano New Issue
2018-03-22 22:35 Stephano Status new => assigned
2018-03-22 22:35 Stephano Assigned To => Michael Van Canneyt
2018-03-23 08:39 Michael Van Canneyt Note Added: 0107356
2018-03-23 08:39 Michael Van Canneyt Status assigned => resolved
2018-03-23 08:39 Michael Van Canneyt Resolution open => unable to reproduce
2018-03-23 10:46 Stephano Note Added: 0107360
2018-03-23 10:46 Stephano Status resolved => assigned
2018-03-23 10:46 Stephano Resolution unable to reproduce => reopened
2018-03-23 10:53 Michael Van Canneyt Note Added: 0107361
2018-03-23 10:53 Michael Van Canneyt Status assigned => feedback
2018-03-23 11:02 Stephano Note Added: 0107362
2018-03-23 11:02 Stephano Status feedback => assigned
2018-03-23 11:09 Stephano Note Added: 0107364
2018-03-23 11:14 Michael Van Canneyt Note Added: 0107366
2018-03-23 11:20 Michael Van Canneyt Fixed in Revision => 57558
2018-03-23 11:20 Michael Van Canneyt Note Added: 0107368
2018-03-23 11:20 Michael Van Canneyt Status assigned => resolved
2018-03-23 11:20 Michael Van Canneyt Fixed in Version => 1.9 (SVN)
2018-03-23 11:20 Michael Van Canneyt Resolution reopened => fixed
2018-03-23 11:27 Stephano Status resolved => closed