View Issue Details

IDProjectCategoryView StatusLast Update
0033509LazarusPackagespublic2018-03-25 19:37
ReporterStephanoAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.9 (SVN)Product Build 
Target VersionFixed in Version1.9 (SVN) 
Summary0033509: FPReport designer: Changing page name in the OI isn't immediately reflected in the tabs
Description- Create a new report
- Change the page name from page1 to page9 for instance
The tab at the top will still show "Page 1 (Page1)".
- Add a new page or save and reload the report
The tab at the top will show "Page 1 (Page9)".
TagsNo tags attached.
Fixed in Revision57561
LazTarget-
Widgetset
Attached Files

Activities

Michael Van Canneyt

2018-03-25 12:31

administrator   ~0107404

I can't reproduce this. It works OK here.

Stephano

2018-03-25 12:41

developer   ~0107405

Last edited: 2018-03-25 12:42

View 2 revisions

There was a missing step:
- Create a new report
- Add a child band <-----
- Change the page name from page1 to page9 for instance
The tab at the top will still show "Page 1 (Page1)".
- Add a new page or save and reload the report
The tab at the top will show "Page 1 (Page9)".

Michael Van Canneyt

2018-03-25 19:32

administrator   ~0107412

Fixed, thanks for reporting!

Issue History

Date Modified Username Field Change
2018-03-24 21:36 Stephano New Issue
2018-03-24 21:36 Stephano Status new => assigned
2018-03-24 21:36 Stephano Assigned To => Michael Van Canneyt
2018-03-25 12:31 Michael Van Canneyt Note Added: 0107404
2018-03-25 12:31 Michael Van Canneyt Status assigned => feedback
2018-03-25 12:41 Stephano Note Added: 0107405
2018-03-25 12:41 Stephano Status feedback => assigned
2018-03-25 12:42 Stephano Note Edited: 0107405 View Revisions
2018-03-25 19:32 Michael Van Canneyt Fixed in Revision => 57561
2018-03-25 19:32 Michael Van Canneyt Note Added: 0107412
2018-03-25 19:32 Michael Van Canneyt Status assigned => resolved
2018-03-25 19:32 Michael Van Canneyt Fixed in Version => 1.9 (SVN)
2018-03-25 19:32 Michael Van Canneyt Resolution open => fixed
2018-03-25 19:37 Stephano Status resolved => closed