View Issue Details

IDProjectCategoryView StatusLast Update
0033514FPCPackagespublic2018-04-22 10:33
ReporterStephanoAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionProduct Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0033514: FPReport designer: Aggregate variable isn't reset correctly
DescriptionLoad the attached report and preview it.
The department sums in the employee group and data footers (SumDeptSalary) are both wrong and different, and the total sum (SumSalary) in the department data footer is wrong.

Also SumDeptSalary values differ (all values are wrong) depending on the group reset condition (employee.dept_no or department.dept_no).

What is the effect of page.Data? If not set, errors can popup.

Finally, there is a memory leak just by loading the report and quitting.
TagsNo tags attached.
Fixed in Revision38803
FPCOldBugId
FPCTarget
Attached Files

Activities

Stephano

2018-03-25 20:33

developer  

MasterDetailGroupedListFB.json (43,986 bytes)

Michael Van Canneyt

2018-04-21 18:02

administrator  

GroupedListFB.json (26,282 bytes)

Michael Van Canneyt

2018-04-21 18:06

administrator   ~0107894

Fixed aggregates. Memory leak is no longer reproducible.

Stephano

2018-04-21 18:48

developer   ~0107895

Aggregate variables slip off possibly on empty detail subsets.
MasterDetailGroupedListFB.pdf (attached) shows the current output of MasterDetailGroupedListFB.json.
"Software Products Div" is empty, but carries on the same sum as the dept above it. The following dept sums are wrong as well.

Stephano

2018-04-21 18:49

developer  

MasterDetailGroupedListFB.pdf (183,240 bytes)

Michael Van Canneyt

2018-04-21 21:37

administrator   ~0107901

OK.
Because I added a "First 3" to list of departments (to speed up debugging) I didn't notice these special cases. :(

They should be OK now. The case of a detail with 1 record should now also be fixed.

Stephano

2018-04-22 10:33

developer   ~0107909

Thanks for fixing!
However there are related bugs that popped up, and which i will report separately.

Issue History

Date Modified Username Field Change
2018-03-25 20:33 Stephano New Issue
2018-03-25 20:33 Stephano Status new => assigned
2018-03-25 20:33 Stephano Assigned To => Michael Van Canneyt
2018-03-25 20:33 Stephano File Added: MasterDetailGroupedListFB.json
2018-04-21 18:02 Michael Van Canneyt File Added: GroupedListFB.json
2018-04-21 18:02 Michael Van Canneyt Project Lazarus => FPC
2018-04-21 18:06 Michael Van Canneyt Fixed in Revision => 38801
2018-04-21 18:06 Michael Van Canneyt Note Added: 0107894
2018-04-21 18:06 Michael Van Canneyt Status assigned => resolved
2018-04-21 18:06 Michael Van Canneyt Fixed in Version => 3.1.1
2018-04-21 18:06 Michael Van Canneyt Resolution open => fixed
2018-04-21 18:06 Michael Van Canneyt Target Version => 3.2.0
2018-04-21 18:48 Stephano Note Added: 0107895
2018-04-21 18:48 Stephano Status resolved => feedback
2018-04-21 18:48 Stephano Resolution fixed => reopened
2018-04-21 18:49 Stephano File Added: MasterDetailGroupedListFB.pdf
2018-04-21 21:37 Michael Van Canneyt Fixed in Revision 38801 => 38803
2018-04-21 21:37 Michael Van Canneyt Note Added: 0107901
2018-04-21 21:37 Michael Van Canneyt Status feedback => resolved
2018-04-21 21:37 Michael Van Canneyt Resolution reopened => fixed
2018-04-22 10:33 Stephano Note Added: 0107909
2018-04-22 10:33 Stephano Status resolved => closed