View Issue Details

IDProjectCategoryView StatusLast Update
0033575LazarusIDEpublic2018-05-28 11:35
ReporterRik van Kekem Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWin32/Win64OSWindows 
Product Version1.9 (SVN) 
Summary0033575: Calling procedurelist on 125% dpi display crashes with "InvalidatePreferredSize loop detected"
DescriptionWhen calling Search > Procedure List (Alt+G) on a display set at 125% the IDE will crash with:
TControl.InvalidatePreferredSize loop detected TB:TToolBar Bounds=l=0,t=0,r=950,b=32.

When the procedurelist.lfm is touched (@ 125% dpi) and saved and the IDE is recompiled it works correctly because the lfm is saved for 125%.
Steps To ReproduceIn standard trunk (or even Lazarus 1.8.2), call the Procedure List (Alt+G) and the crash will happen (when your screen is set at 125%).
Additional InformationSomehow in 125% the TB (TToolbar) keeps setting the cfAutoSizeNeeded in Form.FControlFlags for TProcedureListForm which results in the loop (I think).

See forum topic:
https://forum.lazarus.freepascal.org/index.php/topic,40795.0.html
TagsNo tags attached.
Fixed in Revision57674
LazTarget1.8.4
Widgetset
Attached Files

Relationships

related to 0028654 resolvedOndrej Pokorny Setting Contraints-Value has no effect 
has duplicate 0033590 resolvedMichl Alt+G Procedure List would show error and have to kill the IDE 
related to 0033792 resolvedOndrej Pokorny TToolButton dont align rigth on TToolBar 

Activities

Rik van Kekem

2018-04-06 17:28

reporter   ~0107650

This is also an issue on Windows 10 @ 125%.

eyfpc

2018-04-10 08:47

reporter   ~0107728

I have the very same error on Windows 7 with 135% DPI.

Ondrej Pokorny

2018-04-19 14:26

developer   ~0107867

Regression after r57082.

Ondrej Pokorny

2018-04-19 16:53

developer   ~0107875

The bug was neither in r57082 nor in scaling.

The problem was in the toolbar itself - inherited AlignControls and WrapButtons worked against each other. I disabled inherited AlignControls - it has no meaning in the toolbar code because the controls are aligned with WrapButtons.

Rik van Kekem

2018-04-20 10:49

reporter   ~0107884

Confirmed fixed. Thanks.

Issue History

Date Modified Username Field Change
2018-04-06 17:23 Rik van Kekem New Issue
2018-04-06 17:28 Rik van Kekem Note Added: 0107650
2018-04-09 05:37 Ondrej Pokorny Assigned To => Ondrej Pokorny
2018-04-09 05:37 Ondrej Pokorny Status new => assigned
2018-04-09 14:42 Michl Relationship added has duplicate 0033590
2018-04-10 08:47 eyfpc Note Added: 0107728
2018-04-19 14:25 Ondrej Pokorny Relationship added related to 0028654
2018-04-19 14:26 Ondrej Pokorny Note Added: 0107867
2018-04-19 16:53 Ondrej Pokorny Fixed in Revision => 57674
2018-04-19 16:53 Ondrej Pokorny LazTarget => 1.8.4
2018-04-19 16:53 Ondrej Pokorny Note Added: 0107875
2018-04-19 16:53 Ondrej Pokorny Status assigned => resolved
2018-04-19 16:53 Ondrej Pokorny Resolution open => fixed
2018-04-20 10:49 Rik van Kekem Note Added: 0107884
2018-04-20 10:49 Rik van Kekem Status resolved => closed
2018-05-28 11:35 Ondrej Pokorny Relationship added related to 0033792