View Issue Details

IDProjectCategoryView StatusLast Update
0033585LazarusIDEpublic2018-05-18 21:54
ReporterAlexey Tor.Assigned ToMichl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUbuntu 17 x64OSOS Version
Product Version1.9 (SVN)Product Build 
Target Version1.8.4Fixed in Version1.9 (SVN) 
Summary0033585: OI filter input: caret jumps to begin
DescriptionObjInspector filter field - on entering text, caret goes to 0 and input breaks- i enter "show" and get "wohs".
TagsNo tags attached.
Fixed in Revision57957
LazTarget1.8.4
WidgetsetGTK 2
Attached Files

Activities

Alexey Tor.

2018-04-08 09:22

reporter  

OI-input.png (52,744 bytes)
OI-input.png (52,744 bytes)

Alexey Tor.

2018-05-14 22:27

reporter   ~0108297

No one does see it on gtk2? Then close, local issue

Michl

2018-05-17 14:40

developer   ~0108364

Last edited: 2018-05-18 21:53

View 3 revisions

> No one does see it on gtk2? Then close, local issue
You have to select a property first, then the bug is visible here on GTK2 and Qt.

The problem is, that TListFilterEdit.AutoSelect doesn't work correct on that widgetsets, if the focus is changed fast. See little test app.

But at least the focus has not to be set from PropFilterEdit to CurrentEdit and back to PropFilterEdit. I fixed this in trunk revision 57957. Please test and close if ok.

Michl

2018-05-17 14:41

developer  

test.zip (1,962 bytes)

Issue History

Date Modified Username Field Change
2018-04-08 09:22 Alexey Tor. New Issue
2018-04-08 09:22 Alexey Tor. File Added: OI-input.png
2018-05-14 22:27 Alexey Tor. Note Added: 0108297
2018-05-17 11:58 Michl Assigned To => Michl
2018-05-17 11:58 Michl Status new => assigned
2018-05-17 14:40 Michl Note Added: 0108364
2018-05-17 14:41 Michl File Added: test.zip
2018-05-17 14:41 Michl File Added: objectinspector.pp.patch
2018-05-17 14:44 Michl Note Edited: 0108364 View Revisions
2018-05-18 21:53 Michl Note Edited: 0108364 View Revisions
2018-05-18 21:54 Michl Fixed in Revision => 57957
2018-05-18 21:54 Michl LazTarget => 1.8.4
2018-05-18 21:54 Michl Status assigned => resolved
2018-05-18 21:54 Michl Fixed in Version => 1.9 (SVN)
2018-05-18 21:54 Michl Resolution open => fixed
2018-05-18 21:54 Michl Target Version => 1.8.4
2018-05-18 21:54 Michl File Deleted: objectinspector.pp.patch