View Issue Details

IDProjectCategoryView StatusLast Update
0033602LazarusLCLpublic2018-12-12 07:43
ReporterLagunov AlekseyAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.9 (SVN)Product Build 
Target Version1.10Fixed in Version1.9 (SVN) 
Summary0033602: patch - new methods for DBImage - compataible with delphi
Descriptionadd new methods
    procedure CopyToClipboard;
    procedure CutToClipboard;
    procedure PasteFromClipboard;
    property PictureLoaded : boolean read FPictureLoaded;

make LoadPicture public
TagsNo tags attached.
Fixed in Revision58697
LazTarget1.10
Widgetset
Attached Files

Activities

Lagunov Aleksey

2018-04-12 12:57

reporter  

dbimage.zip (229,340 bytes)

Jesus Reyes

2018-04-17 09:59

developer   ~0107828

Last edited: 2018-04-17 10:03

View 3 revisions

Aleksey, here (windows 10) not all the clipboard features work.

CopyToClipboard and CutToClipboard put the image into the clipboard in JPEG format which is not compatible for sharing between other windows apps, it seems only bmp format is valid for that purpose.

Even it doesnt work from within your test project itself, for example select first record (big cheetah), press "Copy to clipboard" button, select record 2, and press "Paste from clipboard", it will not work

(not tested Linux this time)

Pasting images from other apps into the test project works though.

For solving issues with clipboard I recommend a tool I made for this purpose, see ccr -> applications -> clipanalizer

At least in Windows, I think if image is not in bmp format, an additional format should be added to the clipboard in bmp format (or convert it to bmp and put that format instead). If you want to support pasting jpeg images, a more detailed process should be implemented so you have to analyze all available clipboard formats and choose the correct one.

I think it's a little more difficult because in case there are multiple image formats in the clipboard, which of them will the user prefer?

comments?

Jesus Reyes

2018-08-12 21:00

developer   ~0110005

Applied the patch with changes, Please test.

Issue History

Date Modified Username Field Change
2018-04-12 12:57 Lagunov Aleksey New Issue
2018-04-12 12:57 Lagunov Aleksey File Added: dbimage.zip
2018-04-17 07:52 Jesus Reyes Assigned To => Jesus Reyes
2018-04-17 07:52 Jesus Reyes Status new => assigned
2018-04-17 09:59 Jesus Reyes LazTarget => -
2018-04-17 09:59 Jesus Reyes Note Added: 0107828
2018-04-17 09:59 Jesus Reyes Status assigned => feedback
2018-04-17 10:01 Jesus Reyes Note Edited: 0107828 View Revisions
2018-04-17 10:03 Jesus Reyes Note Edited: 0107828 View Revisions
2018-08-12 21:00 Jesus Reyes Fixed in Revision => 58697
2018-08-12 21:00 Jesus Reyes LazTarget - => 1.10
2018-08-12 21:00 Jesus Reyes Note Added: 0110005
2018-08-12 21:00 Jesus Reyes Status feedback => resolved
2018-08-12 21:00 Jesus Reyes Fixed in Version => 1.9 (SVN)
2018-08-12 21:00 Jesus Reyes Resolution open => fixed
2018-08-12 21:00 Jesus Reyes Target Version => 1.10
2018-12-12 07:43 Lagunov Aleksey Status resolved => closed