View Issue Details

IDProjectCategoryView StatusLast Update
0033632LazarusIDEpublic2018-07-13 20:51
ReporterDavid GrayAssigned ToDmitry Boyarintsev 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSHigh SierraOS Version10.13.4
Product Version1.9 (SVN)Product Build57264 
Target VersionFixed in Version 
Summary0033632: Cocoa: Cmd+Z shortcut (undo) doesn't work in the IDE or an application
DescriptionUndo and redo don't work in the IDE. Specifically, shortcuts involving the cmd+Z (meta Z) key combinations don't seem to reach either the IDE or an app.

Steps To ReproduceType a character into the IDE source editor. Press cmd+Z. Nothing happens. But, select the Edit/Undo IDE main menu and the typed character is correctly removed.

The "redo" shortcut cmd+shift+Z similarly fails.

Or, create a new application and add a main menu. Create a menu item, give it a shortcut of meta Z, create an event handler. The event handler is never called via the shortcut, only via the menu item.

Cmd with other keys does work. For example cmd+Y shortcut works fine.

When fixing, please check that cmd+shift+Z also works, for the "redo" function.
TagsNo tags attached.
Fixed in Revision58456
LazTarget-
WidgetsetCocoa
Attached Files

Relationships

related to 0033171 closedDmitry Boyarintsev Cocoa: Some TMenuItem shortcuts ignored when TMemo is on form 

Activities

David Gray

2018-04-22 20:06

reporter   ~0107935

If TForm.KeyPreview is enabled, no KeyDown or KeyUp event is fired when cmd+Z is pressed. So no workaround is possible.

Ondrej Pokorny

2018-05-16 00:10

reporter   ~0108323

I have the same problem with cmd+left, cmd+shift+left, cmd+right, cmd+shift+right, cmd+up, cmd+down (I disabled the system-wide shortcuts). The shortcuts work in Carbon IDE but not in Cocoa IDE.

Chris Rorden

2018-05-19 14:27

reporter   ~0108425

As a reporter, I do not have permission to add a relationship, but this is a duplicate of or related to 0033171.

Marcus Fernstrom

2018-06-19 00:10

reporter   ~0108960

It works on Carbon, not sure why but it doesn't work on Cocoa.

Dmitry Boyarintsev

2018-07-07 08:59

developer   ~0109256

please test and close if ok

Marcus Fernstrom

2018-07-10 21:56

reporter   ~0109352

Dmitry, when I try to build to trunk using fpcupdeluxe, I get warnings about pseudoterminat, and this error:
lazarus/debugger/pseudoterminaldlg.pp(207, 50) identifier ident no member "DevicePtyMaster"

As well as
lazarus/debugger/pseudoterminaldlg.pp(207, 65) Syntax Error, ";" expected but "]" found

And fails to build.

Martin Friebe

2018-07-11 11:19

manager   ~0109356

pseudoterminaldlg: fixed last night

Marcus Fernstrom

2018-07-11 15:37

reporter   ~0109360

Martin, still getting the ident no member error.

Marcus Fernstrom

2018-07-11 17:28

reporter   ~0109362

I was just able to build with Trunk, but now I'm getting an Arithmetic Overflow error when starting Lazarus, and I can't get past it.

If I choose Abort, of course the whole thing closes.

If I choose Ok, the error goes away but it doesn't finish loading.

There is a window with title "MainIDE", if I try to resize it I get the arithmetic error again.

Marcus Fernstrom

2018-07-11 17:46

reporter   ~0109365

And now success. I had to rebuild again using lazbuild, and now command+z works.

Marcus Fernstrom

2018-07-11 17:49

reporter   ~0109366

Big thanks everyone!

Issue History

Date Modified Username Field Change
2018-04-22 20:01 David Gray New Issue
2018-04-22 20:06 David Gray Note Added: 0107935
2018-05-16 00:10 Ondrej Pokorny Note Added: 0108323
2018-05-19 14:27 Chris Rorden Note Added: 0108425
2018-05-20 11:04 Ondrej Pokorny Relationship added related to 0033171
2018-06-19 00:10 Marcus Fernstrom Note Added: 0108960
2018-07-07 08:59 Dmitry Boyarintsev Fixed in Revision => 58456
2018-07-07 08:59 Dmitry Boyarintsev LazTarget => -
2018-07-07 08:59 Dmitry Boyarintsev Note Added: 0109256
2018-07-07 08:59 Dmitry Boyarintsev Status new => resolved
2018-07-07 08:59 Dmitry Boyarintsev Resolution open => fixed
2018-07-07 08:59 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2018-07-10 21:56 Marcus Fernstrom Note Added: 0109352
2018-07-11 11:19 Martin Friebe Note Added: 0109356
2018-07-11 15:37 Marcus Fernstrom Note Added: 0109360
2018-07-11 17:28 Marcus Fernstrom Note Added: 0109362
2018-07-11 17:46 Marcus Fernstrom Note Added: 0109365
2018-07-11 17:49 Marcus Fernstrom Note Added: 0109366