View Issue Details

IDProjectCategoryView StatusLast Update
0033715LazarusIDEpublic2018-06-12 18:49
ReporterwpAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0033715: Incorrect syntax highlighting of $IF directives
DescriptionSyntax highlighting of $IFDEF cases is an excellent feature of the IDE. It does not work as expected however for $IF directives.
Steps To ReproduceLoad the attached demo into Lazarus trunk (v1.9). I would expect that the case for {$IF LCL_FUllVersion >= 1090000} is displayed normally, and the {$ELSE] case is dimmed. But this is not true. The code, however, is executed correctly.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0030109 confirmed IDE editor: {$if} doesn't evaluate constants 

Activities

wp

2018-05-09 10:30

developer  

IF_Highlighting.zip (1,813 bytes)

Bart Broersma

2018-05-09 19:08

developer   ~0108217

Last edited: 2018-05-09 19:09

View 2 revisions

This is a duplicate, I'll try to find the original one.
[Edit] Yep: 0030109.

Issue History

Date Modified Username Field Change
2018-05-09 10:30 wp New Issue
2018-05-09 10:30 wp File Added: IF_Highlighting.zip
2018-05-09 10:32 wp Description Updated View Revisions
2018-05-09 10:32 wp Steps to Reproduce Updated View Revisions
2018-05-09 19:08 Bart Broersma Note Added: 0108217
2018-05-09 19:09 Bart Broersma Note Edited: 0108217 View Revisions
2018-05-09 19:09 Bart Broersma Relationship added duplicate of 0030109
2018-05-09 19:09 Bart Broersma Status new => resolved
2018-05-09 19:09 Bart Broersma Resolution open => duplicate
2018-05-09 19:09 Bart Broersma Assigned To => Bart Broersma
2018-06-12 18:49 wp Status resolved => closed