View Issue Details

IDProjectCategoryView StatusLast Update
0033799LazarusLCLpublic2021-02-26 15:53
Reportersembit Assigned ToJesus Reyes  
PrioritynormalSeverityminorReproducibilityalways
Status feedbackResolutionreopened 
Platformx64OSWindows 
Product Version1.8.2 
Target Version2.2Fixed in Version1.9 (SVN) 
Summary0033799: TDBGrid: scrolling with option dgThumbTracking
DescriptionChanged the behavior of the component when scrolling. Previously, portions of data were loaded immediately when dragging the slider, and now we need to scroll to the end and release the mouse button to load the next portion of the data. This is inconvenient when you need to scroll to the end of the list. Is it a bug or a new feature? In the attachment test project, try to run it and scroll to the end of the list.
Additional InformationIn 1.8.4, the same problem.
TagsNo tags attached.
Fixed in Revision58055
LazTarget2.0.4
WidgetsetWin32/Win64
Attached Files

Activities

sembit

2018-05-29 07:58

reporter  

TestDBGrid.7z (1,987,545 bytes)

Jesus Reyes

2018-05-29 08:34

developer   ~0108570

When you say previously, exactly to what version or revision of Lazarus are you referring to?

sembit

2018-05-29 09:38

reporter   ~0108571

In Lazarus 1.7.

sembit

2018-05-29 19:27

reporter   ~0108574

... and in Lazarus 1.6.4

Jesus Reyes

2018-05-31 00:06

developer   ~0108599

Please test.

sembit

2018-05-31 10:15

reporter   ~0108605

Unfortunately, the problem is not completely solved. After scrolling to the end, there is a jump up on some record. The video should show:
Lazarus 1.7: https://youtu.be/g-ZNrUARxBI
Lazarus 1.9: https://youtu.be/uZ7tdAPfxQs

As far as I understand, you did the revision only in version 1.9, because in 1.8.5 SVN the problem remains.

Jesus Reyes

2018-05-31 15:27

developer   ~0108618

Yes, I can reproduce the problem, sometimes. I will take a look.
Yes, the fix goes first to trunk then it can be merged to fixes if it can.

sembit

2018-05-31 17:11

reporter   ~0108622

Also noticed that after loading the data, there is a jump to a certain number of records forward.

sembit

2018-06-19 17:11

reporter   ~0108969

The problem has not been solved yet. Can it be possible to change the status?

Jesus Reyes

2018-06-19 18:17

developer   ~0108970

Sure

sembit

2018-10-04 07:21

reporter   ~0111230

The problem is not solved.

sembit

2019-06-14 20:59

reporter   ~0116722

If a correction is not planned to be completed in the near future, then I think it is better to comment out this correction, since it became worse than it was before the correction.

Jesus Reyes

2019-06-18 02:44

developer   ~0116766

The problem that I detected I fixed, and it didn't get worse. But sometimes this kind of problem can happen when two persons do not follow with precision the steps to reproduce the problem, you previously posted a couple of videos showing the problem, can you please post a third one showing the worsening of the problem?, thanks.

Issue History

Date Modified Username Field Change
2018-05-29 07:58 sembit New Issue
2018-05-29 07:58 sembit File Added: TestDBGrid.7z
2018-05-29 08:34 Jesus Reyes Note Added: 0108570
2018-05-29 09:38 sembit Note Added: 0108571
2018-05-29 19:27 sembit Note Added: 0108574
2018-05-30 23:59 Jesus Reyes Assigned To => Jesus Reyes
2018-05-30 23:59 Jesus Reyes Status new => assigned
2018-05-31 00:06 Jesus Reyes Fixed in Revision => 58055
2018-05-31 00:06 Jesus Reyes LazTarget => 1.8.6
2018-05-31 00:06 Jesus Reyes Note Added: 0108599
2018-05-31 00:06 Jesus Reyes Status assigned => resolved
2018-05-31 00:06 Jesus Reyes Fixed in Version => 1.9 (SVN)
2018-05-31 00:06 Jesus Reyes Resolution open => fixed
2018-05-31 00:06 Jesus Reyes Target Version => 1.8.5 (SVN)
2018-05-31 10:15 sembit Note Added: 0108605
2018-05-31 15:27 Jesus Reyes Note Added: 0108618
2018-05-31 17:11 sembit Note Added: 0108622
2018-06-19 17:11 sembit Note Added: 0108969
2018-06-19 18:17 Jesus Reyes Note Added: 0108970
2018-10-04 07:21 sembit Note Added: 0111230
2018-10-04 07:21 sembit Status resolved => assigned
2018-10-04 07:21 sembit Resolution fixed => reopened
2019-06-14 20:59 sembit Note Added: 0116722
2019-06-18 02:44 Jesus Reyes Status assigned => feedback
2019-06-18 02:44 Jesus Reyes LazTarget 1.8.6 => 2.0.4
2019-06-18 02:44 Jesus Reyes Note Added: 0116766
2021-02-26 15:53 Martin Friebe Target Version 1.8.5 (SVN) => 2.2