View Issue Details

IDProjectCategoryView StatusLast Update
0033830LazarusDocumentationpublic2020-04-04 15:54
ReporterTony Rigden Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformWindows 10 
Summary0033830: IDE Help Files do not appear to match the actual IDE
DescriptionThe help files seem to be installed OK and open OK but their contents do not match what I see in the IDE. For example the tools menu description in the help file is:

[next] [prev] [prev-tail] [tail] [up]

6.4.8 The Tools menu

The ”Tools” menu defines some standard tools. If new tools are defined by the user, they are appended to this menu as well.

Messages

(F11) Shows the messages window. This window contains the output from one of the tools. For more information, see section 6.10.1, page 259.

Goto next

(Alt-F8) Goes to the next message.

Goto previous

(Alt-F7) Goes to the previous message

Grep

(SHIFT-F2) Prompts for a regular expression and options to be given to grep, and then executes
grep
with the given expression and options. For this to work, the
grep
program must be installed on the system, and be in a directory that is in the
PATH
. For more information, see section 6.10.2, page 262.

Calculator

Displays the calculator. For more information, see section 6.10.4, page 267.

Ascii table

Displays the
ASCII
table. For more information, see section 6.10.3, page 263.

[next] [prev] [prev-tail] [front] [up]

However, what I see in the IDE is as per the attached picture below
Steps To ReproduceOpen the help file from the Help Menu Item
Go to User's Guide/The IDE/The Menu/The Tools Menu Help Topic
Compare the content with the actual Tools Menu Dropdown.
Additional InformationI have searched the internet for this and found nothing. I left a comment asking for help on this on the forum at http://forum.lazarus.freepascal.org/index.php/topic,41488.0.html
but no replies.

Am I reading the help file wrong or what?
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Tony Rigden

2018-06-06 12:40

reporter  

Marco van de Voort

2018-06-06 15:06

manager   ~0108718

Does invoking the help in this menu really show said topic ?

That topic is probably for the textmode IDE of Free Pascal itself, not lazarus.

The Lazarus IDE help is afaik not in the helpfiles, but only online.

Tony Rigden

2018-06-07 21:39

reporter   ~0108741

If these help files are for the text mode IDE, then why is the Windows Lazarus IDE opening these help files when you click the Help submenu (bottom item) on the Help Menu? Why does not the Menu only show the online help item?

Tony Rigden

2018-06-07 21:42

reporter   ~0108742

PS Also if one uses the online help from Windows Lazarus IDE we get exactly the same help files.

Maxim Ganetsky

2019-12-05 23:35

developer   ~0119649

Please retest with latest Lazarus release (2.0.6) and clean profile.

Juha Manninen

2020-04-04 15:54

developer   ~0121899

No feedback. Resolving.

Issue History

Date Modified Username Field Change
2018-06-06 12:40 Tony Rigden New Issue
2018-06-06 12:40 Tony Rigden Status new => assigned
2018-06-06 12:40 Tony Rigden Assigned To => Michael Van Canneyt
2018-06-06 12:40 Tony Rigden File Added: Screenshot - 5_06_2018 , 9_48_53 PM.jpg
2018-06-06 13:02 Marco van de Voort Project FPC => Lazarus
2018-06-06 15:06 Marco van de Voort Note Added: 0108718
2018-06-07 21:39 Tony Rigden Note Added: 0108741
2018-06-07 21:42 Tony Rigden Note Added: 0108742
2019-12-05 23:23 Michael Van Canneyt Assigned To Michael Van Canneyt =>
2019-12-05 23:31 Maxim Ganetsky Status assigned => new
2019-12-05 23:31 Maxim Ganetsky Product Version 3.0.4 =>
2019-12-05 23:31 Maxim Ganetsky LazTarget => -
2019-12-05 23:35 Maxim Ganetsky Assigned To => Maxim Ganetsky
2019-12-05 23:35 Maxim Ganetsky Status new => feedback
2019-12-05 23:35 Maxim Ganetsky Note Added: 0119649
2019-12-05 23:36 Maxim Ganetsky Assigned To Maxim Ganetsky =>
2020-04-04 15:54 Juha Manninen Assigned To => Juha Manninen
2020-04-04 15:54 Juha Manninen Status feedback => resolved
2020-04-04 15:54 Juha Manninen Resolution open => unable to reproduce
2020-04-04 15:54 Juha Manninen Note Added: 0121899