View Issue Details

IDProjectCategoryView StatusLast Update
0033853Lazarus CCRPackagespublic2018-07-28 18:05
ReporterScott Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformWindows (x86)OSMicrosoft Windows XP Pro SP 3 
Summary0033853: DCPhashes: incorrect hash for files > 4GB
DescriptionWhen using MD5, SHA1, or SHA256, the hash result for any file that is 4 GB or larger calculates incorrectly.
TagsNo tags attached.
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0031934 new Component DCPHashes, which are part of DCPCrypt do not calculate Hashes correctly for files greatre than 4 GB 

Activities

Bart Broersma

2018-06-26 13:42

developer   ~0109066

Updated summary to reflect the problem.

Bart Broersma

2018-07-28 18:05

developer   ~0109722

Please close this one.

Issue History

Date Modified Username Field Change
2018-06-12 07:08 Scott New Issue
2018-06-12 16:45 Bart Broersma Project Lazarus => Lazarus CCR
2018-06-26 13:42 Bart Broersma Note Added: 0109066
2018-06-26 13:42 Bart Broersma Summary DCPhashes part of DCPCrypt Component => DCPhashes: incorrect hash for files > 4GB
2018-07-28 18:05 Bart Broersma Note Added: 0109722
2018-07-28 18:05 Bart Broersma Relationship added duplicate of 0031934
2018-07-28 18:05 Bart Broersma Status new => resolved
2018-07-28 18:05 Bart Broersma Resolution open => duplicate
2018-07-28 18:05 Bart Broersma Assigned To => Bart Broersma