View Issue Details

IDProjectCategoryView StatusLast Update
0033881LazarusIDEpublic2020-08-02 19:51
ReporterMichl Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Platform64bitOSWindows 
Product Version1.9 (SVN) 
Summary0033881: Codetools can't handle a specialized class in mode Delphi.
DescriptionCodetools in mode delphi doesn't understand following (mode objfpc works fine):

type
  TBarList = class(specialize TFPGList<TBar>);

When such declaration is done in a implemented unit, CodeTools always stop by code completion <Ctrl> + <Space> at above line.

This error is shown: unit2.pas(17,31) Error: expected ), but TFPGList found
Steps To ReproduceOpen added project and try a code completion in project file.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0033615 resolvedMattias Gaertner [Lazarus: CodeTools] Find Procedure Definition in Mode Delphi + Generics not working 

Activities

Michl

2018-06-20 17:06

developer  

test.zip (1,554 bytes)

delfion

2018-06-20 19:04

reporter   ~0108985

Last edited: 2018-06-20 19:05

View 2 revisions

Since specialize-keyword is not needed in mode Delphi.

Pascal Riekenberg

2020-07-30 10:00

developer   ~0124412

Is specialize-keyword allowed in mode Delphi?

Sven Barth

2020-07-30 13:26

manager   ~0124418

No, it's not. Delphi does not know the specialize or generic generic keywords.

Juha Manninen

2020-07-30 17:44

developer   ~0124425

@Sven,
FPC 3.2 compiles the test project without complaints, thus allowing the specialize-keyword. I think it is a bug. I did not test with FPC trunk.

Sven Barth

2020-07-31 14:29

manager   ~0124432

Last edited: 2020-07-31 14:29

View 2 revisions

@Juha: just tested, trunk correctly complains, but 3.2 indeed does not.

Juha Manninen

2020-08-02 11:48

developer   ~0124486

Ok. FPC trunk behavior is correct and Codetools behavior matches with it. All good.
Resolving as "no change required".

Sven Barth

2020-08-02 19:51

manager   ~0124514

I've also merged the changes to 3.2.1 now.

Issue History

Date Modified Username Field Change
2018-06-20 17:06 Michl New Issue
2018-06-20 17:06 Michl File Added: test.zip
2018-06-20 17:06 Michl Relationship added related to 0033615
2018-06-20 19:04 delfion Note Added: 0108985
2018-06-20 19:05 delfion Note Edited: 0108985 View Revisions
2020-07-30 10:00 Pascal Riekenberg Note Added: 0124412
2020-07-30 13:26 Sven Barth Note Added: 0124418
2020-07-30 17:44 Juha Manninen Note Added: 0124425
2020-07-31 14:29 Sven Barth Note Added: 0124432
2020-07-31 14:29 Sven Barth Note Edited: 0124432 View Revisions
2020-08-02 11:46 Juha Manninen Assigned To => Juha Manninen
2020-08-02 11:46 Juha Manninen Status new => assigned
2020-08-02 11:48 Juha Manninen Status assigned => resolved
2020-08-02 11:48 Juha Manninen Resolution open => no change required
2020-08-02 11:48 Juha Manninen Note Added: 0124486
2020-08-02 19:51 Sven Barth Note Added: 0124514