View Issue Details

IDProjectCategoryView StatusLast Update
0033884PackagesPackagespublic2018-12-16 23:29
ReportervirgoAssigned Towp 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version1.8.4Product Build 
Target Version2.0Fixed in Version2.0 
Summary0033884: TParadoxBlobFileNamePropertyEditor.GetFilter has invalid extension for Paradox blob files
DescriptionParadoxBlobFileNamePropertyEditor.GetFilter sets filter for selecting blob files to "*.bm". But Paradox blob files are with mb extension (typically tablename.mb, never seen different name).
TagsNo tags attached.
Fixed in Revision59829
LazTarget2.0
Widgetset
Attached Files
  • paradox_blobfilter.diff (458 bytes)
    Index: components/paradox/regparadox.pp
    ===================================================================
    --- components/paradox/regparadox.pp	(revision 59686)
    +++ components/paradox/regparadox.pp	(working copy)
    @@ -59,7 +59,7 @@
     
     function TParadoxBlobFileNamePropertyEditor.GetFilter: String;
     begin
    -  Result := SParadoxBlobFiles+' (*.bm)|*.bm';
    +  Result := SParadoxBlobFiles+' (*.mb)|*.mb';
       Result:= Result+ '|'+ inherited GetFilter;
     end;
     
    

Activities

Bart Broersma

2018-12-16 16:23

developer  

paradox_blobfilter.diff (458 bytes)
Index: components/paradox/regparadox.pp
===================================================================
--- components/paradox/regparadox.pp	(revision 59686)
+++ components/paradox/regparadox.pp	(working copy)
@@ -59,7 +59,7 @@
 
 function TParadoxBlobFileNamePropertyEditor.GetFilter: String;
 begin
-  Result := SParadoxBlobFiles+' (*.bm)|*.bm';
+  Result := SParadoxBlobFiles+' (*.mb)|*.mb';
   Result:= Result+ '|'+ inherited GetFilter;
 end;
 

Bart Broersma

2018-12-16 16:26

developer   ~0112604

@wp: you seem to know at least something about paradox.
https://stackoverflow.com/questions/26671089/paradox-database-file seems to suggest that indeed .mb is the correct extension.

wp

2018-12-16 17:46

developer   ~0112612

Fixed in 59829. Thank you for reporting, please close.

Bart Broersma

2018-12-16 18:25

developer   ~0112616

Last edited: 2018-12-16 18:27

View 3 revisions

svn log: "patch by virgo"?
Well, we do share at least one character in our names ;-)

Merge to fixes?
Also: targets are not set in this issue (just for statistics).

wp

2018-12-16 22:25

developer   ~0112626

Excuse me, Bart. Nobody had mentioned the patch in the text, and so I assumed that it was virgo's - I should have looked in the Issue History.

About merging to 2.0RC3: Yes, I put it on the merge list.

About targets: I must confess that I never understood the difference between "LazTarget" and "TargetVersion" and "Fixed in Version". Since you seem to know feel free to set what's missing.

Bart Broersma

2018-12-16 23:29

developer   ~0112635

Target 2.0RC3 is missing...

Issue History

Date Modified Username Field Change
2018-06-21 10:57 virgo New Issue
2018-12-16 16:23 Bart Broersma File Added: paradox_blobfilter.diff
2018-12-16 16:24 Bart Broersma Assigned To => wp
2018-12-16 16:24 Bart Broersma Status new => assigned
2018-12-16 16:26 Bart Broersma Note Added: 0112604
2018-12-16 17:46 wp Note Added: 0112612
2018-12-16 17:46 wp Fixed in Revision => 59829
2018-12-16 17:46 wp LazTarget => -
2018-12-16 17:46 wp Status assigned => resolved
2018-12-16 17:46 wp Resolution open => fixed
2018-12-16 18:25 Bart Broersma Note Added: 0112616
2018-12-16 18:26 Bart Broersma Note Edited: 0112616 View Revisions
2018-12-16 18:27 Bart Broersma Note Edited: 0112616 View Revisions
2018-12-16 22:25 wp Note Added: 0112626
2018-12-16 23:29 Bart Broersma LazTarget - => 2.0
2018-12-16 23:29 Bart Broersma Note Added: 0112635
2018-12-16 23:29 Bart Broersma Fixed in Version => 2.0
2018-12-16 23:29 Bart Broersma Target Version => 2.0