View Issue Details

IDProjectCategoryView StatusLast Update
0033893FPCCompilerpublic2019-12-10 20:56
ReporterDavid JenkinsAssigned ToFlorian 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformOSOSXOS Version
Product Version3.1.1Product Build39241 
Target VersionFixed in Version 
Summary0033893: Compiler with -O3 and -gw throws internal error
DescriptionWhen compiling attached project with -O3 and -gw the compiler throws following error

Error: Internal error 200603251

Appears to be related to UNROLL optimization and dwarf debug symbols. Turning off either UNROLL or debug allows compilation. -O2 passes but -O2 -OoUNROLL fails.
Steps To ReproduceBuild attached lazarus project.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

David Jenkins

2018-06-22 21:49

reporter  

unroll.zip (2,860 bytes)

Thaddy de Koning

2018-06-23 12:40

reporter   ~0109011

Last edited: 2018-06-23 12:41

View 2 revisions

windows and arm-linux are OK with 3.1.1 r39263. I have to test OSX yet.
I tested with fpc -CX -XXs -O3 -B -gw unroll.pas

Florian

2019-12-10 20:56

administrator   ~0119734

Works with current trunk.

Issue History

Date Modified Username Field Change
2018-06-22 21:49 David Jenkins New Issue
2018-06-22 21:49 David Jenkins File Added: unroll.zip
2018-06-23 12:40 Thaddy de Koning Note Added: 0109011
2018-06-23 12:41 Thaddy de Koning Note Edited: 0109011 View Revisions
2019-12-10 20:56 Florian Assigned To => Florian
2019-12-10 20:56 Florian Status new => resolved
2019-12-10 20:56 Florian Resolution open => unable to reproduce
2019-12-10 20:56 Florian FPCTarget => -
2019-12-10 20:56 Florian Note Added: 0119734