View Issue Details

IDProjectCategoryView StatusLast Update
0033967FPCCompilerpublic2020-09-30 21:55
ReporterNitorami Assigned ToFlorian  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformPCOSwindows 
Product Version3.0.4 
Summary0033967: invalid combination of opcode and operand
DescriptionWith FPUTYPE SSE2, instruction set COREAVX and optimisation level 2, the compiler throws an error
 
Asm: [vsqrtss xmmreg,xmmreg,mem128] invalid combination of opcode and operands

There seems to be a conflict between AVX instructions and register variable optimisation.
Steps To ReproduceCompile the attached code with -CfSSE2 -CpCOREAVX -Mobjfpc -O2 -Twin32
Additional InformationCPU-Z reports that my machine supports AVX instruction set.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Nitorami

2018-07-11 22:04

reporter  

mist.pas (389 bytes)

Nitorami

2018-07-11 22:22

reporter   ~0109378

Last edited: 2018-07-11 22:23

View 2 revisions

Note - the issue goes away when generating assembler output(-al)

Florian

2020-09-30 21:55

administrator   ~0126010

Seems to be fixed meanwhile.

Issue History

Date Modified Username Field Change
2018-07-11 22:04 Nitorami New Issue
2018-07-11 22:04 Nitorami File Added: mist.pas
2018-07-11 22:22 Nitorami Note Added: 0109378
2018-07-11 22:23 Nitorami Note Edited: 0109378 View Revisions
2020-09-30 21:55 Florian Assigned To => Florian
2020-09-30 21:55 Florian Status new => resolved
2020-09-30 21:55 Florian Resolution open => no change required
2020-09-30 21:55 Florian FPCTarget => -
2020-09-30 21:55 Florian Note Added: 0126010