View Issue Details

IDProjectCategoryView StatusLast Update
0034064FPCFCLpublic2018-07-30 23:35
ReporterSerge AnvarovAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSOS Version
Product Version3.1.1Product BuildTrunk 39533 
Target Version3.2.0Fixed in Version3.1.1 
Summary0034064: Unable to compile new compiler for Windows in revision 39533
DescriptionError when compiled fcl-net:
Compiling .\fcl-net\src\ssockets.pp
ssockets.pp(1115,11) Error: Identifier not found "ESysEINPROGRESS"
ssockets.pp(1168) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted

Because ESysEINPROGRESS is not defined in Windows rtl, but is defined for other platforms (in errno.inc).
TagsNo tags attached.
Fixed in Revision39535
FPCOldBugId
FPCTarget
Attached Files

Activities

Michael Van Canneyt

2018-07-30 23:35

administrator   ~0109774

There are other issues with that code, but I've fixed compilation.

Issue History

Date Modified Username Field Change
2018-07-30 23:23 Serge Anvarov New Issue
2018-07-30 23:29 Michael Van Canneyt Assigned To => Joost van der Sluis
2018-07-30 23:29 Michael Van Canneyt Status new => assigned
2018-07-30 23:29 Michael Van Canneyt Assigned To Joost van der Sluis => Michael Van Canneyt
2018-07-30 23:35 Michael Van Canneyt Fixed in Revision => 39535
2018-07-30 23:35 Michael Van Canneyt Note Added: 0109774
2018-07-30 23:35 Michael Van Canneyt Status assigned => resolved
2018-07-30 23:35 Michael Van Canneyt Fixed in Version => 3.1.1
2018-07-30 23:35 Michael Van Canneyt Resolution open => fixed
2018-07-30 23:35 Michael Van Canneyt Target Version => 3.2.0