View Issue Details

IDProjectCategoryView StatusLast Update
0034085FPCPackagespublic2018-08-04 10:22
ReporterAlexey Tor.Assigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.0.4Product Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0034085: RegExpr: small refactor
Descriptioni suggest to add function IsCharSpace and use it in 4 places, where used "Pos(..., fSpaceChars)".
add "inline" so it's same speed.
it's good to have func, because later we can improve it to detect in other way.
TagsNo tags attached.
Fixed in Revision39557
FPCOldBugId
FPCTarget
Attached Files

Activities

Michael Van Canneyt

2018-08-03 20:08

administrator   ~0109864

Fixed as suggested.

Issue History

Date Modified Username Field Change
2018-08-03 18:30 Alexey Tor. New Issue
2018-08-03 18:37 Michael Van Canneyt Assigned To => Michael Van Canneyt
2018-08-03 18:37 Michael Van Canneyt Status new => assigned
2018-08-03 20:08 Michael Van Canneyt Fixed in Revision => 39557
2018-08-03 20:08 Michael Van Canneyt Note Added: 0109864
2018-08-03 20:08 Michael Van Canneyt Status assigned => resolved
2018-08-03 20:08 Michael Van Canneyt Fixed in Version => 3.1.1
2018-08-03 20:08 Michael Van Canneyt Resolution open => fixed
2018-08-03 20:08 Michael Van Canneyt Target Version => 3.2.0
2018-08-04 10:22 Alexey Tor. Status resolved => closed