View Issue Details

IDProjectCategoryView StatusLast Update
0034138FPCTextmode IDEpublic2019-09-20 18:59
ReporterMarģers Assigned ToMarco van de Voort  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Platformx86_64OSlinux 
Product Version3.1.1 
Summary0034138: [Textmode ide] if unit has "uses classes;" after compilation fp drops out to command shell
DescriptionLinux - textmode ide from trunk (3.1.1), "uses" has to include unit "classes".

In first it's look like fp has forzen after compilation. Window "Compiling.." shows "Press ESC to cancel", and compilation messages last message is "Assembling freez". At that time freez.o has been already generated.
Press twice Enter and you are in command shell. Screen is not cleared and characters you type are invisible, but by pressing Enter commands are executed.

Steps To Reproducecompile in textmede ide:

{$mode objfpc}
{$h+}

unit freez;
interface
uses classes;

implementation

end.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0035941 confirmedPierre Muller Textmode IDE crashes on compiling generic record 

Activities

Marģers

2018-08-18 19:31

reporter   ~0110135

Following code drop out of fp by error: Segmentation fault

unit testgnrc; { 18.08.2018 }
interface

type
     generic tg < T > = record x, y : T; end;

implementation
end.

Marģers

2018-11-11 12:04

reporter   ~0111905

Problem caused by Compiler Options -> Browser -> (*) local and global browser.

Using generic and browse information together on compilation in ide lead to segmentation fault.

Marģers

2019-09-20 10:18

reporter   ~0118132

This bug report and 0035941 is about the same issue. One can be resolved as duplicate of other.

Issue History

Date Modified Username Field Change
2018-08-16 13:25 Marģers New Issue
2018-08-18 19:31 Marģers Note Added: 0110135
2018-11-11 12:04 Marģers Note Added: 0111905
2019-09-20 10:18 Marģers Note Added: 0118132
2019-09-20 18:09 Marco van de Voort Relationship added duplicate of 0035941
2019-09-20 18:09 Marco van de Voort Assigned To => Marco van de Voort
2019-09-20 18:09 Marco van de Voort Status new => resolved
2019-09-20 18:09 Marco van de Voort Resolution open => duplicate
2019-09-20 18:09 Marco van de Voort FPCTarget => -
2019-09-20 18:59 Marģers Status resolved => closed