View Issue Details

IDProjectCategoryView StatusLast Update
0034209FPCPackagespublic2018-08-31 16:36
ReporterwpAssigned ToSven Barth 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version3.3.1 
Summary0034209: Cannot compile chmcmd with fpc 3.0.4 and trunk
DescriptionCompilation of the chm generater program chmcmd (in packages/chm/src) with fpc 3.0.4 and fpc trunk on Windows aborts with this error message:

Error: Import library not found for c
Error: Import library not found for gmon
Error: Import library not found for cygwin
Error: Import library not found for user32
Error: Import library not found for kernel32
Error: Import library not found for gcc

This is because the project settings contain the options

-gv (Generate code for valgrind)
-pg (Generate code for gprof)

Although not harmful, I think that also the option -gh (use heaptrc) unit should not be set in a user-applicable program.

Removing these options makes the program compile.
TagsNo tags attached.
Fixed in Revision39691
FPCOldBugId
FPCTarget
Attached Files

Activities

Sven Barth

2018-08-31 14:59

manager   ~0110406

I've disabled those options.

Please note that usually chmcmd is built as part of the "make all" without any involvement of the lpi file.

wp

2018-08-31 16:36

reporter   ~0110410

Thank you.

Issue History

Date Modified Username Field Change
2018-08-31 12:48 wp New Issue
2018-08-31 14:59 Sven Barth Fixed in Revision => 39691
2018-08-31 14:59 Sven Barth Note Added: 0110406
2018-08-31 14:59 Sven Barth Status new => resolved
2018-08-31 14:59 Sven Barth Fixed in Version => 3.3.1
2018-08-31 14:59 Sven Barth Resolution open => fixed
2018-08-31 14:59 Sven Barth Assigned To => Sven Barth
2018-08-31 16:36 wp Note Added: 0110410
2018-08-31 16:36 wp Status resolved => closed