View Issue Details

IDProjectCategoryView StatusLast Update
0034223LazarusIDEpublic2018-09-11 11:04
Reporterbald zhang Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.9 (SVN) 
Summary0034223: PathEditor: bad align in 192dpi
Descriptionpath editor of projects, caused by r56826, was bad aligned.
see attached pictures please.
TagsNo tags attached.
Fixed in Revisionr58871
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0034249 closedwp ItemHeight shrinked after first shown when TListBox.Style is OwnerDrawFixed 

Activities

bald zhang

2018-09-05 10:44

reporter  

patheditor-r56826.png (18,369 bytes)   
patheditor-r56826.png (18,369 bytes)   

bald zhang

2018-09-05 10:45

reporter  

patheditor-good.png (21,111 bytes)   
patheditor-good.png (21,111 bytes)   

Juha Manninen

2018-09-05 13:51

developer   ~0110516

I cannot reproduce the problem. Apparently the whole "Search Paths" GroupBox has shifted left and is partly invisible in your screenshot. It means the LCL layout system is buggy with 192dpi.

I changed the anchors a little in r58871. Please test.

bald zhang

2018-09-05 15:52

reporter   ~0110519

win32 widgets is ok now, I'll check it under linux tomorrow.
if it's good also, then we can close it.

bald zhang

2018-09-06 03:44

reporter  

bald zhang

2018-09-06 03:49

reporter   ~0110526

Linux/QT5 is ok.
but meet other issue: the listbox.ItemHeight was half-sized, when open this dialog first time, it's ok, but from second time, it has 80~90% time become half.
on the other hand, the template dialog is ok.
already checked the code, this listbox is OwnerDrawn, it may relate to font size checking.
Linux/QT5 haven't this, only found in win32.

Juha Manninen

2018-09-10 10:00

developer   ~0110604

Height, coordinates or fonts are not defined anywhere in this dialog explicitly.
Items are added with PathListBox.Items.AddObject() in procedure TPathEditorDialog.SetPath.
Looks like a bug in Win32 TListBox when Style=lbOwnerDrawFixed.
Could you please try to reproduce it with a minimal application and open a new report for it. This path editor is too complex and is part of the IDE, thus testing is more difficult.
This issue can be marked as related to the new one. I plan to resolve this one soon.

bald zhang

2018-09-10 11:59

reporter   ~0110606

layout of this dialog is ok in Win32 and QT5, so this could be closed.

I'll make a mininal case for the listbox issue and report another.

Juha Manninen

2018-09-10 23:55

developer   ~0110627

Ok, thanks. Resolving.

bald zhang

2018-09-11 02:07

reporter   ~0110633

this one is ok now.
ListBox issue reported another.

Issue History

Date Modified Username Field Change
2018-09-05 10:44 bald zhang New Issue
2018-09-05 10:44 bald zhang File Added: patheditor-r56826.png
2018-09-05 10:45 bald zhang File Added: patheditor-good.png
2018-09-05 13:27 Juha Manninen Assigned To => Juha Manninen
2018-09-05 13:27 Juha Manninen Status new => assigned
2018-09-05 13:51 Juha Manninen LazTarget => -
2018-09-05 13:51 Juha Manninen Note Added: 0110516
2018-09-05 13:51 Juha Manninen Status assigned => feedback
2018-09-05 15:52 bald zhang Note Added: 0110519
2018-09-05 15:52 bald zhang Status feedback => assigned
2018-09-06 03:44 bald zhang File Added: patheditor-listbox-half-size.png
2018-09-06 03:49 bald zhang Note Added: 0110526
2018-09-10 10:00 Juha Manninen Note Added: 0110604
2018-09-10 10:00 Juha Manninen Status assigned => feedback
2018-09-10 11:59 bald zhang Note Added: 0110606
2018-09-10 11:59 bald zhang Status feedback => assigned
2018-09-10 23:55 Juha Manninen Fixed in Revision => r58871
2018-09-10 23:55 Juha Manninen Note Added: 0110627
2018-09-10 23:55 Juha Manninen Status assigned => resolved
2018-09-10 23:55 Juha Manninen Resolution open => fixed
2018-09-11 02:07 bald zhang Note Added: 0110633
2018-09-11 02:07 bald zhang Status resolved => closed
2018-09-11 11:04 Juha Manninen Relationship added related to 0034249