View Issue Details

IDProjectCategoryView StatusLast Update
0034240LazarusIDEpublic2021-03-01 13:02
ReporterJohn Kozikopoulos Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformwindowsOSwindows 7 
Product Version1.8.4 
Summary0034240: Check boxes on object inspector do not use the value color as font color
Descriptioncheck boxes in object inspector use different font color from the one setup in the value and selected value and highlight font color settings. and creates a bit of an unpleasant situation
Steps To Reproducecheck the background color of object inspector to black and the font color properties to white check boxes will become invisible
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0033440 new [FEATURE REQUEST] Change the theme of entire IDE 
related to 0035375 new Black on black on DBComboBox items on object properties 

Activities

John Kozikopoulos

2018-09-08 08:11

reporter  

objectInspector.png (24,830 bytes)   
objectInspector.png (24,830 bytes)   

Juha Manninen

2018-09-08 22:43

developer   ~0110569

It is TCheckboxThemed in LazControls which is custom drawn, not a native control.
Thus we can fully manage it's colors.
Can you please fix it and upload a patch.

John Kozikopoulos

2018-09-12 16:48

reporter   ~0110689

Last edited: 2018-09-12 16:49

View 2 revisions

To clarify When I say Value I mean the IDE Option value for the object inspector see new screenshot.
Can't promise a patch at the moment, later in the year perhaps.

John Kozikopoulos

2018-09-12 16:48

reporter  

IDEOptions.png (58,033 bytes)   
IDEOptions.png (58,033 bytes)   

wp

2018-09-12 17:47

developer   ~0110699

How can the background color of the object inspector be changed? Is this possible at all? Or do you mean color settings due to theme support of the OS?

In the latter case I think there is no Lazarus bug at all, but a bug in the OS theme support. Enclosed screenshots of Win10 with the "ContrastBlack" theme do support your observations that the captions of the checkboxes are drawn in black. But just switching to another black-background theme, e.g. "Contrast No.2" makes the captions being painted correctly.

wp

2018-09-12 17:48

developer  

Win10-ContrastBlack.png (7,813 bytes)   
Win10-ContrastBlack.png (7,813 bytes)   

wp

2018-09-12 17:48

developer  

Win10-ContrastNo2.png (7,768 bytes)   
Win10-ContrastNo2.png (7,768 bytes)   

wp

2018-09-12 18:58

developer   ~0110701

Last edited: 2018-09-12 19:22

View 2 revisions

> How can the background color of the object inspector be changed? Is this possible at all?

Sorry - I missed note 0110689

Juha Manninen

2021-02-21 13:11

developer   ~0129057

Please test with Lazarus trunk. I tested on Linux and it works.

Juha Manninen

2021-03-01 13:02

developer   ~0129278

I assume it works. Resolving.

Issue History

Date Modified Username Field Change
2018-09-08 08:11 John Kozikopoulos New Issue
2018-09-08 08:11 John Kozikopoulos File Added: objectInspector.png
2018-09-08 22:43 Juha Manninen Note Added: 0110569
2018-09-08 23:20 Juha Manninen LazTarget => -
2018-09-08 23:20 Juha Manninen Summary Check boxieson object inspector do not use the value color as font color => Check boxes on object inspector do not use the value color as font color
2018-09-12 16:48 John Kozikopoulos Note Added: 0110689
2018-09-12 16:48 John Kozikopoulos File Added: IDEOptions.png
2018-09-12 16:49 John Kozikopoulos Note Edited: 0110689 View Revisions
2018-09-12 17:47 wp Note Added: 0110699
2018-09-12 17:48 wp File Added: Win10-ContrastBlack.png
2018-09-12 17:48 wp File Added: Win10-ContrastNo2.png
2018-09-12 18:58 wp Note Added: 0110701
2018-09-12 19:22 wp Note Edited: 0110701 View Revisions
2020-05-17 15:55 Juha Manninen Relationship added related to 0033440
2020-12-08 10:24 Juha Manninen Relationship added related to 0035375
2021-02-21 13:10 Juha Manninen Assigned To => Juha Manninen
2021-02-21 13:10 Juha Manninen Status new => assigned
2021-02-21 13:11 Juha Manninen Note Added: 0129057
2021-02-21 13:14 Juha Manninen Status assigned => feedback
2021-03-01 13:02 Juha Manninen Status feedback => resolved
2021-03-01 13:02 Juha Manninen Resolution open => fixed
2021-03-01 13:02 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2021-03-01 13:02 Juha Manninen Note Added: 0129278