View Issue Details

IDProjectCategoryView StatusLast Update
0034253LazarusLCLpublic2021-04-07 13:40
ReporterBeanzMaster Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
PlatformPCOSWindows 
Product Version1.8.5 (SVN) 
Summary0034253: TSpeedButton Font Color property
DescriptionChange of TSpeedButton Font Color property not take in charge at designtime with object inspector. And not working by code.
Steps To ReproduceFor exemple in code TSpeedButton(Sender).Font.Color := $004F8400 not working
Additional InformationWith TBitBtn it work
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Bart Broersma

2020-12-02 11:42

developer   ~0127317

Last edited: 2020-12-02 11:42

View 2 revisions

This works OK for me.
I can set Font.Color both in OI and in code.
Lazarus 2.1.0 r64121 FPC 3.2.0 i386-win32-win32/win64 on Win10-64

Can you please test with latest stable or trunk version of Lazarus?

Bart Broersma

2021-04-07 13:40

developer   ~0130152

No feedback in a reasonable time.
Resolving.
Please re-open if you can reproduce the issue with latest stable or trunk version of Lazarus.

Issue History

Date Modified Username Field Change
2018-09-11 10:28 BeanzMaster New Issue
2020-12-02 11:42 Bart Broersma Status new => feedback
2020-12-02 11:42 Bart Broersma LazTarget => -
2020-12-02 11:42 Bart Broersma Note Added: 0127317
2020-12-02 11:42 Bart Broersma Note Edited: 0127317 View Revisions
2021-04-07 13:40 Bart Broersma Assigned To => Bart Broersma
2021-04-07 13:40 Bart Broersma Status feedback => resolved
2021-04-07 13:40 Bart Broersma Resolution open => unable to reproduce
2021-04-07 13:40 Bart Broersma Widgetset Win32/Win64 => Win32/Win64
2021-04-07 13:40 Bart Broersma Note Added: 0130152