View Issue Details

IDProjectCategoryView StatusLast Update
0034305FPCCompilerpublic2019-12-28 17:10
Reporterfedan Assigned ToFlorian  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platformx86_64OSLinux 
Product Version3.2.0 
Summary0034305: aasmcpu.pas(1540,31) Error: Compilation raised exception internally
DescriptionIf I compile the compiler with OPT="- O2 -OpCOREI -CpCOREI -CfSSE41 -g- -gl -Xs" flags, I get an error:

...
/bin/mkdir -p x86_64/units/x86_64-linux
/tmp/fpcbuild.tgUTXoMafs/fpcsrc/compiler/ppc1 -Ur -Xs -O2 -n -Fux86_64 -Fusystems -Fu/tmp/fpcbuild.tgUTXoMafs/fpcsrc/rtl/units/x86_64-linux -Fix86_64 -FE. -FUx86_64/units/x86_64-linux -Cg -dRELEASE -O2 -OpCOREI -CpCOREI -CfSSE41 -g- -gl -Xs -dx86_64 -dGDB -dBROWSERLOG -Fux86 -Sew pp.pas
aasmcpu.pas(1540,31) Error: Compilation raised exception internally
Fatal: Compilation aborted
An unhandled exception occurred at $00000000004F6A09:
EAccessViolation: Access violation
  $00000000004F6A09 ELEMENTS, line 1181 of ncon.pas
Steps To Reproducemake clean all OPT="-O2 -OpCOREI -CpCOREI -CfSSE41 -g- -gl -Xs" > build.log 2>&1
Additional Information# Error -OpCOREI -CpCOREI -CfSSE41
# Error -OpCOREI -CpCOREI
# Pass -OpCOREI
# Error -CpCOREI
# Error -OpCOREI -CfSSE41 -CpCOREI
# Pass -OpCOREI -CfSSE41
# Error -CpCOREI -CfSSE41
# Error -CfSSE41 -CpCOREI

In fpc 3.0.5 (from fixes_3_0 branch, rev: 39664) it works.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Florian

2019-12-28 17:10

administrator   ~0120109

Just checked with current trunk and fixes, seems to be fixed meanwhile.

Issue History

Date Modified Username Field Change
2018-09-20 01:49 fedan New Issue
2019-12-28 17:10 Florian Assigned To => Florian
2019-12-28 17:10 Florian Status new => resolved
2019-12-28 17:10 Florian Resolution open => unable to reproduce
2019-12-28 17:10 Florian FPCTarget => -
2019-12-28 17:10 Florian Note Added: 0120109