View Issue Details

IDProjectCategoryView StatusLast Update
0034334LazarusIDEpublic2019-05-24 18:11
ReporterHans Luijten Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOSmacOS 
Product Version1.8.5 (SVN) 
Summary0034334: Open Package Window - Treeview upside down (Regression?)
DescriptionSince the past 2 SVN versions, when opening a package, the treeview bitmap will be upside down and only half of the content will be displayed.
Clicking on the treeview refreshes the view correctly though.
This happens most of the time, but not always - seems when packages have a lot of files (Required Packages not in view) things go OK.

Regression? Maybe related to a previous reported issue https://bugs.freepascal.org/view.php?id=32970
Steps To ReproduceIn IDE menu "Package, choose "Open Package File (*.lpk)" or "Open Recent Package".
Additional InformationLazarus 2.1.0 r59167 FPC 3.0.4 x86_64-darwin-cocoa (alpha)
TagsNo tags attached.
Fixed in Revision61288
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Hans Luijten

2018-09-25 22:43

reporter  

Package.png (66,758 bytes)   
Package.png (66,758 bytes)   

Dmitry Boyarintsev

2018-10-01 05:29

developer   ~0111143

how does it look on HIgh Sierra?

Hans Luijten

2018-10-01 10:05

reporter   ~0111146

Did some tests just now, and cannot reproduce this issue in High Sierra, so it's working fine there it seems.

Hans Luijten

2018-10-01 10:17

reporter   ~0111147

Note with the SVN r59206 and Mojave:
When opening a package right after starting the IDE, _no_ window appears, yet it is listed in the menu. "Center lost window" takes a few click before it appears and the treeview is upside down again (looks like the same issue as mentioned in the wiki http://wiki.freepascal.org/Cocoa_Internals/Canvas#Forced_Repaint).
Tested this SVN version in High Sierra again; There it runs perfectly fine.

From seeing what happens with the IDE and other controls (TLabel en TBCButton seem to experience repaint issues), I guess this is related to Mojave's Cocoa Framework? But you'd know this better than I would, it's just a guess on my end.

I know you said your Mac's can't run [officially] Mojave, if you'd like I can make a clean virtual machine available for you to play with. I run it in Parallels Desktop Lite (free in the App store).

Dmitry Boyarintsev

2019-05-24 17:27

developer   ~0116396

please test and close if ok

Hans Luijten

2019-05-24 18:11

reporter   ~0116397

Resolved! Excellent - Thanks again Dmitry! :-)

Issue History

Date Modified Username Field Change
2018-09-25 22:43 Hans Luijten New Issue
2018-09-25 22:43 Hans Luijten File Added: Package.png
2018-10-01 05:29 Dmitry Boyarintsev Note Added: 0111143
2018-10-01 05:29 Dmitry Boyarintsev LazTarget => -
2018-10-01 05:29 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2018-10-01 05:29 Dmitry Boyarintsev Status new => feedback
2018-10-01 10:05 Hans Luijten Note Added: 0111146
2018-10-01 10:05 Hans Luijten Status feedback => assigned
2018-10-01 10:17 Hans Luijten Note Added: 0111147
2019-05-24 17:27 Dmitry Boyarintsev Status assigned => resolved
2019-05-24 17:27 Dmitry Boyarintsev Resolution open => fixed
2019-05-24 17:27 Dmitry Boyarintsev Fixed in Revision => 61288
2019-05-24 17:27 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2019-05-24 17:27 Dmitry Boyarintsev Note Added: 0116396
2019-05-24 18:11 Hans Luijten Status resolved => closed
2019-05-24 18:11 Hans Luijten Note Added: 0116397