View Issue Details

IDProjectCategoryView StatusLast Update
0034335LazarusIDEpublic2019-06-24 22:57
ReporterHans LuijtenAssigned ToDmitry Boyarintsev 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSmacOSOS Version10.14
Product Version1.8.5 (SVN)Product Buildr59167 
Target VersionFixed in Version 
Summary0034335: Object Inspector - Can no longer scroll through property list
DescriptionSeen at least in the past 2 SVN versions;

Object Inspector no longer responds correctly to scrollbar, mouse wheel, or arrow keys.
Drawing appears incorrect (a property value will move around, drawing issues, etc).
Steps To ReproduceOpen IDE, start a New Project with a form ... try to change some of the properties of that form.
Additional InformationLazarus 2.1.0 r59167 FPC 3.0.4 x86_64-darwin-cocoa (alpha)
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Hans Luijten

2018-09-25 22:49

reporter  

ObjectInspector.png (102,356 bytes)
ObjectInspector.png (102,356 bytes)

Hans Luijten

2018-09-28 15:00

reporter   ~0111061

After some playing with Lazarus under Mojave on several machines (with or without commandline tools for 1.3), I have noticed some additional strange behavior;

When compiling under Mojave, the application behaves strange at times. Controls do not get drawn or refreshed.

When compiling the exact same application under High Sierra, and then running it under Mojave, results in an application that functions correctly.

Since this is a little out of my league, I'm only guessing there may be an issue with the framework used by the compiler?

Hans Luijten

2018-10-01 14:13

reporter   ~0111155

So far I have narrowed it down to a repaint issue.
Resizing for example the controls list in the object inspector, repaints the property list correctly. One does need to do this each time one does scroll.
The Messages Window is affected by this as well.
In Source Code window one sees this every now and then (for example when using the "Find declaration").

Also note that when switching to to Dark Theme, that none of the properties can be read (names become white on a white background, only the maroon "not default" values can be seen).

Dmitry Boyarintsev

2018-10-01 14:47

developer   ~0111156

I did a little research and the origins of the issue are linked to 10.14:
http://wiki.freepascal.org/Cocoa_Internals/OS_Versions#Drawing_Issues

Hans Luijten

2018-10-01 21:51

reporter   ~0111171

Nice Find! Well, not so nice considering it causes issue ;-)

I noticed that indeed Refresh, Update, Invalidate, Repaint and Application.ProcessMessages most of the time do not trigger or help with the "repaint" of a control or form.

However ... when I compile my application under High Sierra and run it under Mojave, everything works fine (in contrast to compile and running it under Mojave).

Dmitry Boyarintsev

2019-06-10 22:16

developer   ~0116665

the issue doesn't seem to be happening in the current trunk
please confirm

Dmitry Boyarintsev

2019-06-24 22:36

developer   ~0116906

no feedback. resolving

Hans Luijten

2019-06-24 22:57

reporter   ~0116908

Thanks again Dmitry!
Apologies for the late response (I was on vacation).

Issue History

Date Modified Username Field Change
2018-09-25 22:49 Hans Luijten New Issue
2018-09-25 22:49 Hans Luijten File Added: ObjectInspector.png
2018-09-28 15:00 Hans Luijten Note Added: 0111061
2018-10-01 14:13 Hans Luijten Note Added: 0111155
2018-10-01 14:47 Dmitry Boyarintsev Note Added: 0111156
2018-10-01 21:51 Hans Luijten Note Added: 0111171
2019-06-10 22:16 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2019-06-10 22:16 Dmitry Boyarintsev Status new => feedback
2019-06-10 22:16 Dmitry Boyarintsev LazTarget => -
2019-06-10 22:16 Dmitry Boyarintsev Note Added: 0116665
2019-06-24 22:36 Dmitry Boyarintsev Status feedback => resolved
2019-06-24 22:36 Dmitry Boyarintsev Resolution open => fixed
2019-06-24 22:36 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2019-06-24 22:36 Dmitry Boyarintsev Note Added: 0116906
2019-06-24 22:57 Hans Luijten Status resolved => closed
2019-06-24 22:57 Hans Luijten Note Added: 0116908