View Issue Details

IDProjectCategoryView StatusLast Update
0034343FPCCompilerpublic2018-09-27 08:55
ReporterPascal RiekenbergAssigned ToPierre Muller 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSWindows 10 x64OS Version1803
Product Version3.3.1Product Build39819 
Target Version3.3.1Fixed in Version3.3.1 
Summary0034343: build for i386-win32
Descriptionwith r39819 build of i386-win32 is not possible anymore
Additional Informationmake[2]: Entering directory `c:/freepascal_trunk/fpc/trunk/packages/fppkg'
Makefile:215: *** The Makefile doesn't support target i386-win32, please run fpcmake first. Stop.
make[2]: Leaving directory `c:/freepascal_trunk/fpc/trunk/packages/fppkg'
make[1]: *** [fppkg_distclean] Error 2
make[1]: Leaving directory `c:/freepascal_trunk/fpc/trunk/packages'
make: *** [packages_distclean] Error 2
TagsNo tags attached.
Fixed in Revision39820
FPCOldBugId
FPCTarget
Attached Files

Activities

Pierre Muller

2018-09-27 08:23

developer   ~0111045

Hello,

  I tried latest trunk checkout 1:39819,
and, starting with 3.0.4 i386-win32 compiler,
I was able to finish successfully a
make distclean all OPT="-n -gl"

  Could you please try the same,
and report if this works for you.
  If you still get a failure, please report precisely
the conditions, with a longer log,
and check that your trunk checkout is not modified.

  Please remember that internal changes to the compiler code
can sometimes lead to the fact that a previous trunk compiler
is not able to compile the most recent version.

Pierre Muller

2018-09-27 08:39

developer   ~0111046

Sorry, I did not see that it
was due to the generated Makefile
in that directory.

  The problem should be fixed after commit #39820.

  Please check and close bug report if that works for you.

  Thanks for reporting the issue.

Issue History

Date Modified Username Field Change
2018-09-27 08:03 Pascal Riekenberg New Issue
2018-09-27 08:23 Pierre Muller Note Added: 0111045
2018-09-27 08:23 Pierre Muller Assigned To => Pierre Muller
2018-09-27 08:23 Pierre Muller Status new => feedback
2018-09-27 08:39 Pierre Muller Fixed in Revision => 39820
2018-09-27 08:39 Pierre Muller Note Added: 0111046
2018-09-27 08:39 Pierre Muller Status feedback => resolved
2018-09-27 08:39 Pierre Muller Fixed in Version => 3.3.1
2018-09-27 08:39 Pierre Muller Resolution open => fixed
2018-09-27 08:39 Pierre Muller Target Version => 3.3.1
2018-09-27 08:55 Pascal Riekenberg Status resolved => closed