View Issue Details

IDProjectCategoryView StatusLast Update
0034398FPCDocumentationpublic2018-10-20 14:35
ReporterUlrich EduardAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.2.0Product Build 
Target Version3.2.0Fixed in Version3.3.1 
Summary0034398: Section 4.4 about initialized variables: Strange Formatting
DescriptionThe remark about the impossibility to write to const memory is difficult to understand.

This is how it looks like after pasting it, but the two attached screenshots from the PDF and the HTML version show the real problem.

Remark: Care should be taken when using initialized pointer types such as PChars. In the following examples, S is a pointer, pointing to a block of constant (read-only) program data. Assigning S
0

will therefor not work. Assigning S itself will of course work.
TagsNo tags attached.
Fixed in Revision1514
FPCOldBugId
FPCTarget
Attached Files

Activities

Ulrich Eduard

2018-10-07 10:56

reporter  

FPC_Chapter_44_png.tar (20,480 bytes)

Marco van de Voort

2018-10-07 15:09

manager   ~0111304

The source looks like this:

Assigning \var{S\[0\]} will therefore not work. Assigning \var{S} itself will
of course work.


Maybe the escape is not good in a remark environment?

Michael Van Canneyt

2018-10-20 14:35

administrator   ~0111486

\[ \] indicates a math environment.

Fixed, thanks for reporting!

Issue History

Date Modified Username Field Change
2018-10-07 10:56 Ulrich Eduard New Issue
2018-10-07 10:56 Ulrich Eduard Status new => assigned
2018-10-07 10:56 Ulrich Eduard Assigned To => Michael Van Canneyt
2018-10-07 10:56 Ulrich Eduard File Added: FPC_Chapter_44_png.tar
2018-10-07 15:09 Marco van de Voort Note Added: 0111304
2018-10-20 14:35 Michael Van Canneyt Fixed in Revision => 1514
2018-10-20 14:35 Michael Van Canneyt Note Added: 0111486
2018-10-20 14:35 Michael Van Canneyt Status assigned => resolved
2018-10-20 14:35 Michael Van Canneyt Fixed in Version => 3.3.1
2018-10-20 14:35 Michael Van Canneyt Resolution open => fixed
2018-10-20 14:35 Michael Van Canneyt Target Version => 3.2.0