View Issue Details

IDProjectCategoryView StatusLast Update
0034438FPCCompilerpublic2019-01-01 23:01
ReporterThaddy de KoningAssigned ToPierre Muller 
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformArmhfOSRaspbianOS VersionJessie
Product Version3.3.1Product Build39986 
Target Version3.3.1Fixed in Version3.3.1 
Summary0034438: Internal error
Description *Lazarus* throws a compiler internal error some time after *fpc* 3.3.1. from at most one day ago.

Output:(3104) Compiling ./gtk2/gtk2proc.pp
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(475,24) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(520,3) Note: (6058) Call to subroutine "function GetDebugLogger:TLazLogger;" marked as inline is not inlined
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(677,39) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(708,24) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(713,47) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(730,18) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(761,32) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(763,34) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.pp(366,40) Hint: (5024) Parameter "AForm" not used
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.pp(368,37) Hint: (5024) Parameter "AForm" not used
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(839,16) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(870,23) Hint: (5060) Function result variable does not seem to be initialized
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(880,40) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(896,18) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(901,29) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(926,18) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(931,29) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(963,7) Note: (6058) Call to subroutine "function GetDebugLogger:TLazLogger;" marked as inline is not inlined
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1054,5) Note: (6058) Call to subroutine "function GetDebugLogger:TLazLogger;" marked as inline is not inlined
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.pp(629,34) Hint: (5024) Parameter "AScaleGC" not used
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1127,5) Note: (6058) Call to subroutine "function GetDebugLogger:TLazLogger;" marked as inline is not inlined
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1224,28) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1238,22) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1333,5) Note: (6058) Call to subroutine "function GetDebugLogger:TLazLogger;" marked as inline is not inlined
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1378,32) Hint: (5057) Local variable "SourceRect" does not seem to be initialized
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1381,3) Note: (6058) Call to subroutine "function GetDebugLogger:TLazLogger;" marked as inline is not inlined
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1409,17) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.pp(389,30) Hint: (5024) Parameter "DC" not used
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1603,5) Note: (6058) Call to subroutine "function GetDebugLogger:TLazLogger;" marked as inline is not inlined
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1774,16) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1779,16) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1787,54) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1797,52) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1806,46) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(1811,44) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(2091,42) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(2309,52) Hint: (5057) Local variable "EventString" does not seem to be initialized
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(2817,34) Hint: (4079) Converting the operands to "Int64" before doing the add could prevent overflow errors.
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(2863,39) Hint: (4079) Converting the operands to "Int64" before doing the add could prevent overflow errors.
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(2914,58) Hint: (4079) Converting the operands to "Int64" before doing the add could prevent overflow errors.
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(3360,39) Hint: (5057) Local variable "ModMap" does not seem to be initialized
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(3388,22) Warning: (5089) Local variable "KeySyms" of a managed type does not seem to be initialized
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(3474,32) Hint: (5057) Local variable "KeySymChars" does not seem to be initialized
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(3592,46) Hint: (4035) Mixing signed expressions and longwords gives a 64bit result
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(3617,19) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(3641,19) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(3824,18) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(3975,5) Note: (6058) Call to subroutine "function GetDebugLogger:TLazLogger;" marked as inline is not inlined
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(3989,5) Note: (6058) Call to subroutine "function GetDebugLogger:TLazLogger;" marked as inline is not inlined
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4013,18) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4157,27) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4240,17) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4242,27) Hint: (5057) Local variable "Mess" does not seem to be initialized
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4281,26) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4475,24) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4476,20) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4515,24) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4516,20) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4705,15) Fatal: Internal error 200108231
Fatal: (1018) Compilation aborted
Error: /usr/local/bin/ppcarm returned an error exitcode
Error: (lazarus) Compile package LCL 2.1: stopped with exit code 256
Error: (lazarus) [TLazPackageGraph.CompileRequiredPackages] "Exit code 256"
Error: (lazarus) Building IDE: Compile AutoInstall Packages failed.
Makefile:3279: recipe for target 'useride' failed
make: *** [useride] Error 2
Steps To Reproducebuild lazarus trunk 59323: make clean useride with fpc 3.3.1-r39986
Additional InformationI did a built last evening that was ok.
The error is with these revisions here:

./ncgbas.pas:534: internalerror(200108231);
TagsNo tags attached.
Fixed in Revision40202
FPCOldBugId
FPCTarget
Attached Files

Relationships

has duplicate 0034466 closedJ. Gareth Moreton Internal error 200108231 
has duplicate 0034495 closedFlorian Can't compile Lazarus on Raspberry Pi3 using fpc 3.3.1 and Larzarus r>57100 
related to 0034786 closedFlorian Fatal: Internal error 200108231 - compiling of Lazarus breaks 

Activities

Thaddy de Koning

2018-10-19 17:51

reporter   ~0111474

Last edited: 2018-10-19 18:02

View 4 revisions

If I revert 39986 it compiles (for some reason at least it continues the second time, but I have a build) . I only tested on Raspbian armhf for now.
Just in case: make clean all useride
for lazarus makes no difference. same internal error
So 39986 is the breaker.

Thaddy de Koning

2018-10-23 07:51

reporter   ~0111518

Last edited: 2018-10-23 07:51

View 2 revisions

To be sure, I tested with a fresh (n.o.t.b) RPi 3.
Same thing:
gtk2proc.inc(4705,15) Fatal: Internal error 200108231
Fatal: Compilation aborted
Makefile:2956: recipe for target '../lcl.ppu' failed
make[3]: *** [../lcl.ppu] Error 1
make[3]: Leaving directory '/home/pi/lazarus/lcl/interfaces/gtk2'
Makefile:3293: recipe for target 'gtk2_all' failed
make[2]: *** [gtk2_all] Error 2
make[2]: Leaving directory '/home/pi/lazarus/lcl/interfaces'
Makefile:4460: recipe for target 'interfaces' failed
make[1]: *** [interfaces] Error 2
make[1]: Leaving directory '/home/pi/lazarus/lcl'
Makefile:3259: recipe for target 'lcl' failed
make: *** [lcl] Error 2

Now with r40016 and Laz trunk

Anton Kavalenka

2018-10-23 08:52

reporter   ~0111519

Does rm -rf lazarus/lcl/units help?

Thaddy de Koning

2018-10-27 13:17

reporter   ~0111612

Last edited: 2018-10-27 13:27

View 2 revisions

No. As I said. I eliminated that by using a completely new, unused, second Raspberry Pi 3. (I have always some stock, since I do a lot with them).
And make clean... does remove everything OK. It is not likely a makefile issue, since makefiles don't throw internal errors....
It is annoying: Lazarus trunk + FPC trunk are broken on armhf-linux, even today's current.

Just in case I just tried your suggestion. Same issue.
gtk2proc.inc(4705,15) Fatal: Internal error 200108231
Fatal: Compilation aborted

Cyrax

2018-10-28 08:30

reporter   ~0111628

Last edited: 2018-10-28 08:38

View 3 revisions

Confirmed.

Running i386 Arch linux in LXC container on x86_64 Arch linux host.

Building for i386-linux.

Trying to build 32-bit Lazarus trunk r59378 with 32-bit FPC r40059 fails with Internal error 200108231.

Also there is stack trace from EAccessViolation exception :
An unhandled exception occurred at $2420200B:
EAccessViolation: Access violation
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B0E
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $2420200B
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $08260E03
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $081DA263
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $0819B503
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $08283F42
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $081DA263
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $08260920
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $081DA263
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $08260920
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $081DA263
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $08266088
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $081DA263
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $08260920
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $081DA263
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $08260920
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA263
  $08260920

  $081DA263
An unhandled exception occurred at $08072340:
EAccessViolation: Access violation
  $08072340
  $08072174
  $0806FFC7
  $08071CD3
  $08071F87
  $080A5B71
  $0805FF7C
  $0806005E
  $080A5E2F
  $08063BBA
  $36303830
  $08260E03
  $081DA263
  $0819B503
  $08283F42
  $081DA269


---

FPC was built with these commands:
make clean all install OPT=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vbq -Sew- -dEXTDEBUG  -dTEST_WIN32_SEH FPC=fpc REVSTR=40059 IDE=1 NOWPOCYCLE=1 INSTALL_PREFIX=/mnt/shares/ohjelmointi2/fpc/i386/trunk/3.3.1/binary/trunk


Using these commands to build Lazarus:
make clean \
all \
FPC=fpc \
"OPT=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -gh -O- -Si- -vb -dHEAPTRC_WINDOW -dDBG_WITH_DEBUGGER_DEBUG -va" \
UPXPROG=echo \
USESVN2REVISIONINC=0


Cyrax

2018-10-28 08:32

reporter  

lazarus build error log.txt.zip (51,571 bytes)

Cyrax

2018-10-28 09:02

reporter   ~0111629

Running x86_64 Arch Linux LXC container. On top x86_64 Arch Linux.

Building for x86_64-linux.

Okay, building x86_64 Lazarus succeeds.

Thaddy de Koning

2018-10-30 09:12

reporter   ~0111671

Last edited: 2018-10-30 09:15

View 2 revisions

Possible cause:

In cpubase.pas the function:

494 function dwarf_reg_no_error(r:tregister):shortint;
495 begin
496 result:=regdwarf_table[findreg_by_number(r)];
497 end;
498

fails when the r parameter is -1, because there is no -1 as an index for the table.

That it fails on the GTK2 units is not surprising because of its register complexity.
See dbgdwarf.pas line 2574 and up why.
That it works on 64 bit is by accident and is prone to the same error but scaled. Can somebody confirm this?

I understand Pierre already had not 100% confidence in the fix in 39986

Pierre Muller

2018-10-30 16:21

developer   ~0111686

Hi,

  findreg_by_number return type is tregisterindex,
which by definition is 0 to #registers -1 in CPU/cpubase.pas unit.

  This function calls findreg_by_number_table
which returns zero if the register is not found,
see rgbase implementation line 61 in trunk.

Thus the index in the table is always valid by the result of the function
is regdwarf_table[0], which is -1, if r is not found.
Maybe inserting a DW_OP_btregx with a value of -1
is wrong, but this should only affect the dwarf debugging information,
not the compilation.

  I was not yet able to reproduce your bug report,
mainly because I do not usually compile lazarus, but got up to
a final linking error on x86_64-linux due to missing libraries.

Cyrax

2018-11-01 17:35

reporter   ~0111727

Finally got call stack from Lazarus:
#0 INTERNALERROR(200108231) at verbose.pas:578
0000001 TCGTEMPREFNODE__PASS_GENERATE_CODE(0xef89a8e0) at ncgbas.pas:534
0000002 SECONDPASS(0xef89a8e0) at pass_2.pas:208
0000003 TCGDEREFNODE__PASS_GENERATE_CODE(0xef06fc70) at ncgmem.pas:266
0000004 TX86DEREFNODE__PASS_GENERATE_CODE(0xef06fc70) at x86/nx86mem.pas:56
0000005 SECONDPASS(0xef06fc70) at pass_2.pas:208
0000006 TCGBLOCKNODE__PASS_GENERATE_CODE(0xef0721d0) at ncgbas.pas:438
0000007 SECONDPASS(0xef0721d0) at pass_2.pas:208
0000008 TCGBLOCKNODE__PASS_GENERATE_CODE(0xef060160) at ncgbas.pas:438
0000009 SECONDPASS(0xef060160) at pass_2.pas:208
0000010 TCGIFNODE__PASS_GENERATE_CODE(0xee2ade60) at ncgflw.pas:324
0000011 SECONDPASS(0xee2ade60) at pass_2.pas:208
0000012 TCGBLOCKNODE__PASS_GENERATE_CODE(0xef0708a0) at ncgbas.pas:438
0000013 SECONDPASS(0xef0708a0) at pass_2.pas:208
0000014 TCGBLOCKNODE__PASS_GENERATE_CODE(0xef072030) at ncgbas.pas:438
0000015 SECONDPASS(0xef072030) at pass_2.pas:208
0000016 DO_SECONDPASS(0xef072030) at pass_2.pas:248
0000017 TCGPROCINFO__GENERATE_CODE(0xf3ffd4f0) at psub.pas:1488
0000018 TCGPROCINFO__GENERATE_CODE_TREE(0xf3ffd4f0) at psub.pas:1130
0000019 TCGPROCINFO__GENERATE_CODE_TREE(0xf4000970) at psub.pas:1135
0000020 READ_PROC_BODY(0xf3ffe210, 0xf0e0ac60) at psub.pas:2082
0000021 READ_PROC(false, 0x0, false) at psub.pas:2279
0000022 READ_DECLARATIONS(false) at psub.pas:2463
0000023 BLOCK(false) at psub.pas:318
0000024 TCGPROCINFO__PARSE_BODY(0xf3ffe210) at psub.pas:1894
0000025 PROC_UNIT at pmodules.pas:1085
0000026 COMPILE('gtk2proc.pp') at parser.pas:385
0000027 TPPUMODULE__LOADPPU(0xf7ef26e0) at fppu.pas:2106
0000028 LOADUNITS(0x0) at pmodules.pas:514
0000029 PROC_UNIT at pmodules.pas:967
0000030 COMPILE('gtk2winapiwindow.pp') at parser.pas:385
0000031 TPPUMODULE__LOADPPU(0xf7ef2a20) at fppu.pas:2106
0000032 LOADUNITS(0x0) at pmodules.pas:514
0000033 PROC_UNIT at pmodules.pas:967
0000034 COMPILE('gtk2int.pas') at parser.pas:385
0000035 TPPUMODULE__LOADPPU(0xf7ef2200) at fppu.pas:2106
0000036 LOADUNITS(0xf145e620) at pmodules.pas:514
0000037 PROC_UNIT at pmodules.pas:1058
0000038 COMPILE('gtk2def.pp') at parser.pas:385
0000039 TPPUMODULE__LOADPPU(0xf7ef19e0) at fppu.pas:2106
0000040 LOADUNITS(0x0) at pmodules.pas:514
0000041 PROC_UNIT at pmodules.pas:967
0000042 COMPILE('gtk2fontcache.pas') at parser.pas:385
0000043 TPPUMODULE__LOADPPU(0xf7ef1ec0) at fppu.pas:2106
0000044 LOADUNITS(0x0) at pmodules.pas:514
0000045 PROC_UNIT at pmodules.pas:967
0000046 COMPILE('gtk2proc.pp') at parser.pas:385
0000047 TPPUMODULE__LOADPPU(0xf7ef26e0) at fppu.pas:2106
0000048 LOADUNITS(0x0) at pmodules.pas:514
0000049 PROC_UNIT at pmodules.pas:967
0000050 COMPILE('gtk2winapiwindow.pp') at parser.pas:385
0000051 TPPUMODULE__LOADPPU(0xf7ef2a20) at fppu.pas:2106
0000052 LOADUNITS(0x0) at pmodules.pas:514
#53 PROC_UNIT at pmodules.pas:967
#54 COMPILE('gtk2int.pas') at parser.pas:385
0000055 TPPUMODULE__LOADPPU(0xf7ef2200) at fppu.pas:2106
0000056 LOADUNITS(0x0) at pmodules.pas:514
0000057 PROC_UNIT at pmodules.pas:967
0000058 COMPILE('gtk2cellrenderer.pas') at parser.pas:385
0000059 TPPUMODULE__LOADPPU(0xf7ef16a0) at fppu.pas:2106
0000060 LOADUNITS(0x0) at pmodules.pas:514
0000061 PROC_UNIT at pmodules.pas:967
0000062 COMPILE('alllclintfunits.pas') at parser.pas:385
0000063 TPPUMODULE__LOADPPU(0xf7ef1360) at fppu.pas:2106
0000064 LOADUNITS(0x0) at pmodules.pas:514
0000065 PROC_UNIT at pmodules.pas:967
0000066 COMPILE('../lcl.pas') at parser.pas:385
0000067 COMPILE(0x0) at compiler.pas:278
0000068 main at pp.pas:276

Cyrax

2018-11-01 17:39

reporter   ~0111728

Got bit more:
#0 GETEXEINMEMORYBASEADDR(0x8260fd3, 0x0, 0000199'A'0000008'p'0000199'A'0000008#211#15'&'0000008'Df'0000255#255't!'0000007#8#255#0#0#0'\s'..., 255) at ../inc/exeinfo.pp:912
0000001 GETMODULEBYADDR(0x8260fd3, 0x0, '/mnt/shares/ohjelmointi2/'...) at ../inc/exeinfo.pp:75
0000002 OPENDWARF(0x8260fd3) at ../inc/lnfodwrf.pp:278
0000003 GETLINEINFO(136712147, '', '', -206915572) at ../inc/lnfodwrf.pp:1301
0000004 DWARFBACKTRACESTR(0x8260fd3) at ../inc/lnfodwrf.pp:1386
0000005 DUMP_STACK({}, 0xffff6e48, 0x8260fd3) at ../inc/system.inc:1300
0000006 DEF_INTERNALERROR(200108231) at comphook.pas:382
0000007 INTERNALERROR(200108231) at verbose.pas:586
0000008 TCGTEMPREFNODE__PASS_GENERATE_CODE(0xef89a8e0) at ncgbas.pas:534
0000009 SECONDPASS(0xef89a8e0) at pass_2.pas:208
0000010 TCGDEREFNODE__PASS_GENERATE_CODE(0xef06fc70) at ncgmem.pas:266
0000011 TX86DEREFNODE__PASS_GENERATE_CODE(0xef06fc70) at x86/nx86mem.pas:56
0000012 SECONDPASS(0xef06fc70) at pass_2.pas:208
0000013 TCGBLOCKNODE__PASS_GENERATE_CODE(0xef0721d0) at ncgbas.pas:438
0000014 SECONDPASS(0xef0721d0) at pass_2.pas:208
0000015 TCGBLOCKNODE__PASS_GENERATE_CODE(0xef060160) at ncgbas.pas:438
0000016 SECONDPASS(0xef060160) at pass_2.pas:208
0000017 TCGIFNODE__PASS_GENERATE_CODE(0xee2ade60) at ncgflw.pas:324
0000018 SECONDPASS(0xee2ade60) at pass_2.pas:208
0000019 TCGBLOCKNODE__PASS_GENERATE_CODE(0xef0708a0) at ncgbas.pas:438
0000020 SECONDPASS(0xef0708a0) at pass_2.pas:208
0000021 TCGBLOCKNODE__PASS_GENERATE_CODE(0xef072030) at ncgbas.pas:438
0000022 SECONDPASS(0xef072030) at pass_2.pas:208
0000023 DO_SECONDPASS(0xef072030) at pass_2.pas:248
0000024 TCGPROCINFO__GENERATE_CODE(0xf3ffd4f0) at psub.pas:1488
0000025 TCGPROCINFO__GENERATE_CODE_TREE(0xf3ffd4f0) at psub.pas:1130
0000026 TCGPROCINFO__GENERATE_CODE_TREE(0xf4000970) at psub.pas:1135
0000027 READ_PROC_BODY(0xf3ffe210, 0xf0e0ac60) at psub.pas:2082
0000028 READ_PROC(false, 0x0, false) at psub.pas:2279
0000029 READ_DECLARATIONS(false) at psub.pas:2463
0000030 BLOCK(false) at psub.pas:318
0000031 TCGPROCINFO__PARSE_BODY(0xf3ffe210) at psub.pas:1894
0000032 PROC_UNIT at pmodules.pas:1085
0000033 COMPILE('gtk2proc.pp') at parser.pas:385
0000034 TPPUMODULE__LOADPPU(0xf7ef26e0) at fppu.pas:2106
0000035 LOADUNITS(0x0) at pmodules.pas:514
0000036 PROC_UNIT at pmodules.pas:967
0000037 COMPILE('gtk2winapiwindow.pp') at parser.pas:385
0000038 TPPUMODULE__LOADPPU(0xf7ef2a20) at fppu.pas:2106
0000039 LOADUNITS(0x0) at pmodules.pas:514
0000040 PROC_UNIT at pmodules.pas:967
0000041 COMPILE('gtk2int.pas') at parser.pas:385
0000042 TPPUMODULE__LOADPPU(0xf7ef2200) at fppu.pas:2106
0000043 LOADUNITS(0xf145e620) at pmodules.pas:514
0000044 PROC_UNIT at pmodules.pas:1058
0000045 COMPILE('gtk2def.pp') at parser.pas:385
0000046 TPPUMODULE__LOADPPU(0xf7ef19e0) at fppu.pas:2106
0000047 LOADUNITS(0x0) at pmodules.pas:514
0000048 PROC_UNIT at pmodules.pas:967
0000049 COMPILE('gtk2fontcache.pas') at parser.pas:385
0000050 TPPUMODULE__LOADPPU(0xf7ef1ec0) at fppu.pas:2106
0000051 LOADUNITS(0x0) at pmodules.pas:514
0000052 PROC_UNIT at pmodules.pas:967
#53 COMPILE('gtk2proc.pp') at parser.pas:385
#54 TPPUMODULE__LOADPPU(0xf7ef26e0) at fppu.pas:2106
0000055 LOADUNITS(0x0) at pmodules.pas:514
0000056 PROC_UNIT at pmodules.pas:967
0000057 COMPILE('gtk2winapiwindow.pp') at parser.pas:385
0000058 TPPUMODULE__LOADPPU(0xf7ef2a20) at fppu.pas:2106
0000059 LOADUNITS(0x0) at pmodules.pas:514
0000060 PROC_UNIT at pmodules.pas:967
0000061 COMPILE('gtk2int.pas') at parser.pas:385
0000062 TPPUMODULE__LOADPPU(0xf7ef2200) at fppu.pas:2106
0000063 LOADUNITS(0x0) at pmodules.pas:514
0000064 PROC_UNIT at pmodules.pas:967
0000065 COMPILE('gtk2cellrenderer.pas') at parser.pas:385
0000066 TPPUMODULE__LOADPPU(0xf7ef16a0) at fppu.pas:2106
0000067 LOADUNITS(0x0) at pmodules.pas:514
0000068 PROC_UNIT at pmodules.pas:967
0000069 COMPILE('alllclintfunits.pas') at parser.pas:385
0000070 TPPUMODULE__LOADPPU(0xf7ef1360) at fppu.pas:2106
0000071 LOADUNITS(0x0) at pmodules.pas:514
0000072 PROC_UNIT at pmodules.pas:967
0000073 COMPILE('../lcl.pas') at parser.pas:385
0000074 COMPILE(0x0) at compiler.pas:278
0000075 main at pp.pas:276

Pierre Muller

2018-11-02 09:03

developer   ~0111740

  I was finally able to reproduce the problem:


gtk2proc.inc(3989,5) Note: Call to subroutine "function GetDebugLogger:TLazLogger;" marked as inline is not inlined

Breakpoint 2, INTERNALERROR (I=200108231) at verbose.pas:572
572 UpdateStatus;
Program not completed(gdb) bt
#0 INTERNALERROR (I=200108231) at verbose.pas:572
0000001 0x00000000006951eb in PASS_GENERATE_CODE (this=0x7fffeae9e300) at ncgbas.pas:534
0000002 0x00000000005fb68d in SECONDPASS (P=0x7fffeae9e300) at pass_2.pas:208
0000003 0x00000000005af93d in PASS_GENERATE_CODE (this=0x7ffff3444a80) at ncgmem.pas:266
0000004 0x00000000005fb68d in SECONDPASS (P=0x7ffff3444a80) at pass_2.pas:208
0000005 0x0000000000694b98 in PASS_GENERATE_CODE (this=0x7ffff343a640) at ncgbas.pas:438
0000006 0x00000000005fb68d in SECONDPASS (P=0x7ffff343a640) at pass_2.pas:208
0000007 0x0000000000694b98 in PASS_GENERATE_CODE (this=0x7ffff343aac0) at ncgbas.pas:438
0000008 0x00000000005fb68d in SECONDPASS (P=0x7ffff343aac0) at pass_2.pas:208
0000009 0x000000000069bd4c in PASS_GENERATE_CODE (this=0x7fffec26d0e0) at ncgflw.pas:326
0000010 0x00000000005fb68d in SECONDPASS (P=0x7fffec26d0e0) at pass_2.pas:208
0000011 0x0000000000694b98 in PASS_GENERATE_CODE (this=0x7ffff343cb60) at ncgbas.pas:438
0000012 0x00000000005fb68d in SECONDPASS (P=0x7ffff343cb60) at pass_2.pas:208
0000013 0x0000000000694b98 in PASS_GENERATE_CODE (this=0x7ffff343b060) at ncgbas.pas:438
0000014 0x00000000005fb68d in SECONDPASS (P=0x7ffff343b060) at pass_2.pas:208
0000015 0x0000000000694b98 in PASS_GENERATE_CODE (this=0x7ffff343ad00) at ncgbas.pas:438
0000016 0x00000000005fb68d in SECONDPASS (P=0x7ffff343ad00) at pass_2.pas:208
0000017 0x00000000005fb786 in DO_SECONDPASS (P=0x7ffff343ad00) at pass_2.pas:248
0000018 0x00000000005cf03f in GENERATE_CODE (this=0x7fffeb773840) at psub.pas:1485
0000019 0x00000000005ce319 in GENERATE_CODE_TREE (this=0x7fffeb773840) at psub.pas:1127
0000020 0x00000000005ce331 in GENERATE_CODE_TREE (this=0x7fffeb770240) at psub.pas:1132
0000021 0x00000000005d09ee in READ_PROC_BODY (OLD_CURRENT_PROCINFO=0x7fffeb76e040, PD=0x7fffece67840) at psub.pas:2079
0000022 0x00000000005d1047 in READ_PROC (ISCLASSMETHOD=false, USEFWPD=0x0, ISGENERIC=false) at psub.pas:2276
0000023 0x00000000005d16b2 in READ_DECLARATIONS (ISLIBRARY=false) at psub.pas:2460
0000024 0x00000000005cb9f8 in BLOCK (ISLIBRARY=false) at psub.pas:318
0000025 0x00000000005d02a1 in PARSE_BODY (this=0x7fffeb76e040) at psub.pas:1891
0000026 0x00000000006864d5 in PROC_UNIT () at pmodules.pas:1085
0000027 0x0000000000647450 in COMPILE (FILENAME=...) at parser.pas:385
0000028 0x0000000000678757 in LOADPPU (this=0x7ffff7fda4b0) at fppu.pas:2106
0000029 0x00000000006778ac in LOAD_USEDUNITS (this=0x7ffff7fdaab0) at fppu.pas:1725
0000030 0x000000000067847f in LOADPPU (this=0x7ffff7fdaab0) at fppu.pas:2051
0000031 0x00000000006778ac in LOAD_USEDUNITS (this=0x7ffff7fd9bb0) at fppu.pas:1725
0000032 0x000000000067847f in LOADPPU (this=0x7ffff7fd9bb0) at fppu.pas:2051
0000033 0x0000000000684a53 in LOADUNITS (PRESERVEST=0x7fffed0edb00) at pmodules.pas:514
0000034 0x0000000000686307 in PROC_UNIT () at pmodules.pas:1058
0000035 0x0000000000647450 in COMPILE (FILENAME=...) at parser.pas:385
0000036 0x0000000000678757 in LOADPPU (this=0x7ffff7fd8cb0) at fppu.pas:2106
0000037 0x00000000006778ac in LOAD_USEDUNITS (this=0x7ffff7fd95b0) at fppu.pas:1725
0000038 0x000000000067847f in LOADPPU (this=0x7ffff7fd95b0) at fppu.pas:2051
0000039 0x0000000000684a53 in LOADUNITS (PRESERVEST=0x0) at pmodules.pas:514
0000040 0x0000000000685ee4 in PROC_UNIT () at pmodules.pas:967
0000041 0x0000000000647450 in COMPILE (FILENAME=...) at parser.pas:385
0000042 0x0000000000678757 in LOADPPU (this=0x7ffff7fda4b0) at fppu.pas:2106
0000043 0x00000000006778ac in LOAD_USEDUNITS (this=0x7ffff7fdaab0) at fppu.pas:1725
0000044 0x000000000067847f in LOADPPU (this=0x7ffff7fdaab0) at fppu.pas:2051
0000045 0x00000000006778ac in LOAD_USEDUNITS (this=0x7ffff7fd9bb0) at fppu.pas:1725
0000046 0x000000000067847f in LOADPPU (this=0x7ffff7fd9bb0) at fppu.pas:2051
0000047 0x00000000006778ac in LOAD_USEDUNITS (this=0x7ffff7677c10) at fppu.pas:1725
0000048 0x000000000067847f in LOADPPU (this=0x7ffff7677c10) at fppu.pas:2051
0000049 0x0000000000684a53 in LOADUNITS (PRESERVEST=0x0) at pmodules.pas:514
0000050 0x0000000000685ee4 in PROC_UNIT () at pmodules.pas:967
0000051 0x0000000000647450 in COMPILE (FILENAME=...) at parser.pas:385
0000052 0x0000000000678757 in LOADPPU (this=0x7ffff7673910) at fppu.pas:2106
#53 0x0000000000684a53 in LOADUNITS (PRESERVEST=0x0) at pmodules.pas:514
#54 0x0000000000685ee4 in PROC_UNIT () at pmodules.pas:967
0000055 0x0000000000647450 in COMPILE (FILENAME=...) at parser.pas:385
0000056 0x0000000000434061 in COMPILE (CMD=0x0) at compiler.pas:278
0000057 0x00000000004003f7 in main () at pp.pas:276
(gdb) f this^
current stack frame does not contain a variable named `this'
(gdb) f 1
0000001 0x00000000006951eb in PASS_GENERATE_CODE (this=0x7fffeae9e300) at ncgbas.pas:534
534 internalerror(200108231);
(gdb) f this^
warning: can't find linker symbol for virtual table for `TCGTEMPREFNODE' value
Value can't be converted to integer.
(gdb) p /x this^
warning: can't find linker symbol for virtual table for `TCGTEMPREFNODE' value
$10 = {<TTEMPREFNODE> = {<TTEMPBASENODE> = {<TNODE> = {<TOBJECT> = {_vptr$TOBJECT = 0xa29d90}, FPPUIDX = 0x0, NODETYPE = 0x42, BLOCKTYPE = 0x0, EXPECTLOC = 0x6, LOCATION = {LOC = 0x0, SIZE = 0x0,
          RESFLAGS = 0x0, VALUE = 0x0, VALUE64 = 0x0, REFERENCE = {OFFSET = 0x0, SYMBOL = 0x0, RELSYMBOL = 0x0, TEMPPOS = {VAL = 0x0}, BASE = 0x0, INDEX = 0x0, REFADDR = 0x0, SCALEFACTOR = 0x0,
            SYMBOLDATA = 0x0, SIGNINDEX = 0x0, SHIFTIMM = 0x0, ADDRESSMODE = 0x0, SHIFTMODE = 0x0, VOLATILITY = [], ALIGNMENT = 0x0}, REGISTER = 0x0, REGISTERHI = 0x0, REGISTER64 = {REGLO = 0x0, REGHI = 0x0},
          SREG = {SUBSETREG = 0x0, STARTBIT = 0x0, BITLEN = 0x0, SUBSETREGSIZE = 0x0}, SREF = {REF = {OFFSET = 0x0, SYMBOL = 0x0, RELSYMBOL = 0x0, TEMPPOS = {VAL = 0x0}, BASE = 0x0, INDEX = 0x0, REFADDR = 0x0,
              SCALEFACTOR = 0x0, SYMBOLDATA = 0x0, SIGNINDEX = 0x0, SHIFTIMM = 0x0, ADDRESSMODE = 0x0, SHIFTMODE = 0x0, VOLATILITY = [], ALIGNMENT = 0x0}, BITINDEXREG = 0x0, STARTBIT = 0x0, BITLEN = 0x0},
          TRUELABEL = 0x0, FALSELABEL = 0x0}, PARENT = 0x0, SUCCESSOR = 0x0, FLAGS = [NF_PASS1_DONE], RESULTDEF = 0x7fffeb2aa880, RESULTDEFDEREF = {DATAIDX = 0x0}, FILEINFO = {LINE = 0x1261, COLUMN = 0xf,
          FILEINDEX = 0x3, MODULEINDEX = 0xf}, LOCALSWITCHES = [CS_CHECK_IO, CS_TYPED_CONST_WRITABLE, CS_DO_INLINE, CS_IMPORTED_DATA, CS_REFCOUNTEDSTRINGS, CS_POINTERMATH], VERBOSITY = 0x101f,
        OPTINFO = 0x7fffeab2bc40}, TEMPINFO = 0x7fffeb2c7f20}, TEMPIDX = 0x0}, }
(gdb) p /x this^.TEMPINFO^
warning: can't find linker symbol for virtual table for `TCGTEMPREFNODE' value
$11 = {FLAGS = [TI_MAY_BE_IN_REG], HOOKONCOPY = 0x0, TYPEDEF = 0x7fffeb2aa880, TYPEDEFDEREF = {DATAIDX = 0x0}, TEMPTYPE = 0x3, OWNER = 0x7fffeb3b9b00, WITHNODE = 0x0, LOCATION = {LOC = 0x6, SIZE = 0x3,
    RESFLAGS = 0x40, VALUE = 0x1000040, VALUE64 = 0x1000040, REFERENCE = {OFFSET = 0x1000040, SYMBOL = 0x0, RELSYMBOL = 0x0, TEMPPOS = {VAL = 0x0}, BASE = 0x0, INDEX = 0x0, REFADDR = 0x0, SCALEFACTOR = 0x0,
      SYMBOLDATA = 0x0, SIGNINDEX = 0x0, SHIFTIMM = 0x0, ADDRESSMODE = 0x0, SHIFTMODE = 0x0, VOLATILITY = [], ALIGNMENT = 0x0}, REGISTER = 0x1000040, REGISTERHI = 0x0, REGISTER64 = {REGLO = 0x1000040,
      REGHI = 0x0}, SREG = {SUBSETREG = 0x1000040, STARTBIT = 0x0, BITLEN = 0x0, SUBSETREGSIZE = 0x0}, SREF = {REF = {OFFSET = 0x1000040, SYMBOL = 0x0, RELSYMBOL = 0x0, TEMPPOS = {VAL = 0x0}, BASE = 0x0,
        INDEX = 0x0, REFADDR = 0x0, SCALEFACTOR = 0x0, SYMBOLDATA = 0x0, SIGNINDEX = 0x0, SHIFTIMM = 0x0, ADDRESSMODE = 0x0, SHIFTMODE = 0x0, VOLATILITY = [], ALIGNMENT = 0x0}, BITINDEXREG = 0x0,
      STARTBIT = 0x0, BITLEN = 0x0}, TRUELABEL = 0x1000040, FALSELABEL = 0x0}, TEMPINITCODE = 0x0}

  It seems like a temprefnode is modified by optimization,
but not fully handled. Please note that:
(gdb) p this^
warning: can't find linker symbol for virtual table for `TCGTEMPREFNODE' value
$12 = {<TTEMPREFNODE> = {<TTEMPBASENODE> = {<TNODE> = {<TOBJECT> = {_vptr$TOBJECT = 0xa29d90}, FPPUIDX = 0, NODETYPE = TEMPREFN, BLOCKTYPE = BT_NONE, EXPECTLOC = LOC_CREGISTER, LOCATION = {LOC = LOC_INVALID,
          SIZE = OS_NO, RESFLAGS = F_EQ, VALUE = 0, VALUE64 = 0, REFERENCE = {OFFSET = 0, SYMBOL = 0x0, RELSYMBOL = 0x0, TEMPPOS = {VAL = 0}, BASE = (unknown: 0), INDEX = (unknown: 0), REFADDR = ADDR_NO,
            SCALEFACTOR = 0, SYMBOLDATA = 0x0, SIGNINDEX = 0, SHIFTIMM = 0, ADDRESSMODE = AM_OFFSET, SHIFTMODE = SM_NONE, VOLATILITY = [], ALIGNMENT = 0}, REGISTER = (unknown: 0), REGISTERHI = (unknown: 0),
          REGISTER64 = {REGLO = (unknown: 0), REGHI = (unknown: 0)}, SREG = {SUBSETREG = (unknown: 0), STARTBIT = 0, BITLEN = 0, SUBSETREGSIZE = OS_NO}, SREF = {REF = {OFFSET = 0, SYMBOL = 0x0,
              RELSYMBOL = 0x0, TEMPPOS = {VAL = 0}, BASE = (unknown: 0), INDEX = (unknown: 0), REFADDR = ADDR_NO, SCALEFACTOR = 0, SYMBOLDATA = 0x0, SIGNINDEX = 0, SHIFTIMM = 0, ADDRESSMODE = AM_OFFSET,
              SHIFTMODE = SM_NONE, VOLATILITY = [], ALIGNMENT = 0}, BITINDEXREG = (unknown: 0), STARTBIT = 0, BITLEN = 0}, TRUELABEL = 0x0, FALSELABEL = 0x0}, PARENT = 0x0, SUCCESSOR = 0x0,
        FLAGS = [NF_PASS1_DONE], RESULTDEF = 0x7fffeb2aa880, RESULTDEFDEREF = {DATAIDX = 0}, FILEINFO = {LINE = 4705, COLUMN = 15, FILEINDEX = 3, MODULEINDEX = 15},
        LOCALSWITCHES = [CS_CHECK_IO, CS_TYPED_CONST_WRITABLE, CS_DO_INLINE, CS_IMPORTED_DATA, CS_REFCOUNTEDSTRINGS, CS_POINTERMATH], VERBOSITY = 4127, OPTINFO = 0x7fffeab2bc40}, TEMPINFO = 0x7fffeb2c7f20},
    TEMPIDX = 0}, }

  NF_PASS1_DONE seems to state that pass1 was executed on that node,
but at the same time, LOC is still LOC_INVALID.

Issue History

Date Modified Username Field Change
2018-10-19 17:44 Thaddy de Koning New Issue
2018-10-19 17:51 Thaddy de Koning Note Added: 0111474
2018-10-19 17:52 Thaddy de Koning Note Edited: 0111474 View Revisions
2018-10-19 18:01 Thaddy de Koning Note Edited: 0111474 View Revisions
2018-10-19 18:02 Thaddy de Koning Note Edited: 0111474 View Revisions
2018-10-23 07:51 Thaddy de Koning Note Added: 0111518
2018-10-23 07:51 Thaddy de Koning Note Edited: 0111518 View Revisions
2018-10-23 08:52 Anton Kavalenka Note Added: 0111519
2018-10-27 09:23 J. Gareth Moreton Priority normal => urgent
2018-10-27 09:23 J. Gareth Moreton Severity minor => crash
2018-10-27 09:24 J. Gareth Moreton Relationship added has duplicate 0034466
2018-10-27 13:17 Thaddy de Koning Note Added: 0111612
2018-10-27 13:27 Thaddy de Koning Note Edited: 0111612 View Revisions
2018-10-28 08:30 Cyrax Note Added: 0111628
2018-10-28 08:31 Cyrax Note Edited: 0111628 View Revisions
2018-10-28 08:32 Cyrax File Added: lazarus build error log.txt.zip
2018-10-28 08:38 Cyrax Note Edited: 0111628 View Revisions
2018-10-28 09:02 Cyrax Note Added: 0111629
2018-10-30 09:12 Thaddy de Koning Note Added: 0111671
2018-10-30 09:15 Thaddy de Koning Note Edited: 0111671 View Revisions
2018-10-30 16:21 Pierre Muller Note Added: 0111686
2018-11-01 17:35 Cyrax Note Added: 0111727
2018-11-01 17:39 Cyrax Note Added: 0111728
2018-11-02 09:03 Pierre Muller Note Added: 0111740
2018-11-02 09:03 Pierre Muller Assigned To => Pierre Muller
2018-11-02 09:03 Pierre Muller Status new => confirmed
2018-11-02 09:03 Pierre Muller Target Version => 3.3.1
2018-11-03 18:31 Florian Fixed in Revision => 40202
2018-11-03 18:31 Florian Status confirmed => resolved
2018-11-03 18:31 Florian Fixed in Version => 3.3.1
2018-11-03 18:31 Florian Resolution open => fixed
2018-11-03 18:32 Florian Relationship added has duplicate 0034495
2019-01-01 23:01 Florian Relationship added related to 0034786