View Issue Details

IDProjectCategoryView StatusLast Update
0034479FPCFCLpublic2019-02-16 17:25
ReporterM.AUDIO Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSLubuntu lxde 
Product Version3.3.1 
Summary0034479: Artifacts in TImageList when importing image with transparent background
DescriptionIn short,
If I compile my LAZ r59378 with FPC r39747 importing an image with transparent areas in the the background is fine when lazarus resizes it to my specified resolutions. (attach 0000001)
but
If I compile my LAZ r59378 with FPC r39748 then importing an image with transparent areas in the the background produces artifacts when lazarus resizes it to my specified resolutions. (attach 0000002)
Steps To Reproducesample project + graphics (attach 0000003).
Additional InformationI'm not sure if the bugracker issue 0034266 is the problem, or it's something in the lazarus side that needs to be changed to support? that commit. so I don't know where is the best place for this report.
Please feel free to move it to the right place.
Tagsalpha, artifact, image, ImageList, img, resize, transparent
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

related to 0034266 closedMichael Van Canneyt TFPCustomCanvas.Draw and .StretchDraw do not support alpha-blended images 

Activities

M.AUDIO

2018-10-29 21:28

reporter  

imglistresize01.png (243,036 bytes)   
imglistresize01.png (243,036 bytes)   

M.AUDIO

2018-10-29 21:29

reporter  

imglistresize02.png (188,887 bytes)   
imglistresize02.png (188,887 bytes)   

M.AUDIO

2018-10-29 21:30

reporter  

wp

2018-10-30 01:27

reporter   ~0111668

Cannot reproduce on Win 10/64 bit with today's Laz trunk (r59392) and today's fpc trunk (r40091) (32 bit).

M.AUDIO

2018-10-30 09:25

reporter   ~0111672

Freshly installed FPC r40095 and LAZ r59392, it still available on GTK2 linux.
It started from FPC r39748 as mentioned.

Marco van de Voort

2018-10-30 11:55

manager   ~0111679

Note there is also a transparency related fcl-image rev, r39973

M.AUDIO

2019-01-27 13:53

reporter   ~0113662

Any news on this?

Still available with fpc 41084 and laz 60230
I have to undo that patch (FPC r39748) every time I update laz+fpc.
Is the author of that patch aware of this issue? I can't see s/he's email to inform him.

Ondrej Pokorny

2019-02-01 11:37

developer   ~0113770

Thanks for reporting the bug. I'll work on it.

Ondrej Pokorny

2019-02-16 13:51

developer   ~0114179

M.AUDIO, can you check with the new FPC trunk?

M.AUDIO

2019-02-16 15:31

reporter   ~0114183

Ondrej, Tested with FPC r41342 and LAZ r60437
Thank you for fixing it.

Michael Van Canneyt

2019-02-16 17:25

administrator   ~0114190

Thanks for the patch, Ondrej

Issue History

Date Modified Username Field Change
2018-10-29 21:28 M.AUDIO New Issue
2018-10-29 21:28 M.AUDIO File Added: imglistresize01.png
2018-10-29 21:29 M.AUDIO File Added: imglistresize02.png
2018-10-29 21:30 M.AUDIO File Added: imglistresizertransparentproblem.zip
2018-10-29 21:31 M.AUDIO Tag Attached: image
2018-10-29 21:31 M.AUDIO Tag Attached: ImageList
2018-10-29 21:31 M.AUDIO Tag Attached: alpha
2018-10-29 21:31 M.AUDIO Tag Attached: artifact
2018-10-29 21:31 M.AUDIO Tag Attached: img
2018-10-29 21:31 M.AUDIO Tag Attached: resize
2018-10-29 21:31 M.AUDIO Tag Attached: transparent
2018-10-30 01:27 wp Note Added: 0111668
2018-10-30 09:25 M.AUDIO Note Added: 0111672
2018-10-30 11:55 Marco van de Voort Note Added: 0111679
2018-10-31 09:44 Michael Van Canneyt Relationship added related to 0034266
2019-01-27 13:53 M.AUDIO Note Added: 0113662
2019-02-01 11:37 Ondrej Pokorny Note Added: 0113770
2019-02-16 13:51 Ondrej Pokorny Note Added: 0114179
2019-02-16 15:22 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-02-16 15:22 Michael Van Canneyt Status new => assigned
2019-02-16 15:31 M.AUDIO Note Added: 0114183
2019-02-16 17:25 Michael Van Canneyt Note Added: 0114190
2019-02-16 17:25 Michael Van Canneyt Status assigned => resolved
2019-02-16 17:25 Michael Van Canneyt Resolution open => fixed