View Issue Details

IDProjectCategoryView StatusLast Update
0034484LazarusWidgetsetpublic2019-05-22 21:45
ReporterCudaText man Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformmacOS 10.8 
Product Version2.1 (SVN) 
Summary0034484: Cocoa: bug with Align=alClient and child forms
DescriptionRun added demo, with Cocoa WS x64.
Drag splitter a little; then make drag of low window border up/down - do it hard, with big mouse moves.
Result: not OK aligned child forms.
Example screenshot added.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCocoa
Attached Files

Relationships

related to 0035599 assignedDmitry Boyarintsev Cocoa: Splitter with alBottom bug on resize 

Activities

CudaText man

2018-10-30 17:02

reporter  

CudaText man

2018-10-30 17:03

reporter  

cocoa-split1.png (300,441 bytes)

Dmitry Boyarintsev

2019-05-22 21:06

developer   ~0116347

seems to be resolved with 0035599
please test and close if ok

Issue History

Date Modified Username Field Change
2018-10-30 17:02 CudaText man New Issue
2018-10-30 17:02 CudaText man File Added: tst_cocoa_splitter_bug.zip
2018-10-30 17:03 CudaText man File Added: cocoa-split1.png
2019-05-22 21:05 Dmitry Boyarintsev Relationship added related to 0035599
2019-05-22 21:06 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2019-05-22 21:06 Dmitry Boyarintsev Status new => resolved
2019-05-22 21:06 Dmitry Boyarintsev Resolution open => fixed
2019-05-22 21:06 Dmitry Boyarintsev LazTarget => -
2019-05-22 21:06 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2019-05-22 21:06 Dmitry Boyarintsev Note Added: 0116347
2019-05-22 21:45 CudaText man Status resolved => closed