View Issue Details

IDProjectCategoryView StatusLast Update
0034495FPCCompilerpublic2018-11-03 19:30
ReporterValdas JankūnasAssigned ToFlorian 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformlinux armOSRaspbian Stretch 2018-10-09OS Version
Product Version3.3.1Product Build> 57100 
Target VersionFixed in Version 
Summary0034495: Can't compile Lazarus on Raspberry Pi3 using fpc 3.3.1 and Larzarus r>57100
DescriptionI have Raspberry Pi3 B with fresh Raspbian Stretch (image 2018-10-09) on it.

I need FPC trunk because a Bug (https://bugs.freepascal.org/view.php?id=32005) so I followed these instructions and successfully compiled FPC from trunk r40152 (using 'OPT="-dFPC_ARMHF"'): https://bigdanzblog.wordpress.com/2015/06/13/compiling-the-latest-lazarusfree-pascal-for-raspberry-pi/
I used same instructions to download and compile Lazarus 2.1.0 from trunk from SVN, but I cant compile it because compilation aborts with lines:

gtk2proc.inc(4631,15) Fatal: Internal error 200108231
Fatal: Compilation aborted
Makefile:2956: recipe for target '../lcl.ppu' failed
make[3]: *** [../lcl.ppu] Error 1
make[3]: Leaving directory '/usr/local/lazarus/source/lcl/interfaces/gtk2'
Makefile:3293: recipe for target 'gtk2_all' failed
make[2]: *** [gtk2_all] Error 2
make[2]: Leaving directory '/usr/local/lazarus/source/lcl/interfaces'
Makefile:4460: recipe for target 'interfaces' failed
make[1]: *** [interfaces] Error 2
make[1]: Leaving directory '/usr/local/lazarus/source/lcl'
Makefile:3243: recipe for target 'lcl' failed
make: *** [lcl] Error 2

For info compilation starts with lines:

# make all OPT="-dFPC_ARMHF"
make -C packager/registration
make[1]: Entering directory '/usr/local/lazarus/source/packager/registration'
/bin/rm -f ../units/arm-linux/fcllaz.ppu
/usr/local/bin/ppcarm -MObjFPC -Scghi -O1 -g -gl -l -vewnhibq -Fu. -Fu/usr/local/lib/fpc/3.3.1/units/arm-linux/rtl -FE. -FU../units/arm-linux -dFPC_ARMHF -darm fcllaz.pas
Hint: (11030) Start of reading config file /etc/fpc.cfg
Hint: (11031) End of reading config file /etc/fpc.cfg
Free Pascal Compiler version 3.3.1 [2018/11/01] for arm
Copyright (c) 1993-2018 by Florian Klaempfl and others
(1002) Target OS: Linux for ARMHF
(3104) Compiling fcllaz.pas
.....


I tried various revisions (erase previous revision completely -> checkout to different revision):
  - cannot compile: latest, 59000, 58500, 58000, 57500, 57200
  - compiles without errors: 57100 (and I can start it: main window header shows v1.9.0), 57000 (checked two times), 55000
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0034438 resolvedPierre Muller Internal error 

Activities

Cyrax

2018-11-01 23:13

reporter   ~0111734

Already reported https://bugs.freepascal.org/view.php?id=34438

Thaddy de Koning

2018-11-03 09:20

reporter   ~0111753

Yes, it is a duplicate of my report and confirmed. It is being worked on.

Issue History

Date Modified Username Field Change
2018-11-01 23:03 Valdas Jankūnas New Issue
2018-11-01 23:13 Cyrax Note Added: 0111734
2018-11-03 09:20 Thaddy de Koning Note Added: 0111753
2018-11-03 18:32 Florian Relationship added duplicate of 0034438
2018-11-03 18:32 Florian Status new => resolved
2018-11-03 18:32 Florian Resolution open => duplicate
2018-11-03 18:32 Florian Assigned To => Florian
2018-11-03 19:30 Valdas Jankūnas Status resolved => closed