View Issue Details

IDProjectCategoryView StatusLast Update
0034506LazarusIDEpublic2018-11-08 12:05
ReporterBBazAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0RC2Product Build 
Target Version2.0Fixed in Version2.0 
Summary0034506: code editor caret not visible after going back from sparta designer
Description- Have Sparta designer setup.
- click to go to designer
- click to go back to code editor

At this point the caret is not visible anymore and you have to minimize/maximize so that an event get generated which has for effect to restore the caret (there might be other ways to get it back but this doesn't matter)
TagsNo tags attached.
Fixed in Revision59490
LazTarget2.0
WidgetsetGTK 2
Attached Files

Relationships

has duplicate 0034527 closedMartin Friebe Patches Fix issue 34506 - code editor caret not visible after going back from sparta designer 

Activities

Vojtech Cihak

2018-11-04 12:41

reporter   ~0111779

I had invisible carret yesterday with trunk but I don't know what I did (definitely it wasn't caused by Sparta designer since I don't use it). Carret was invisible in one tab only, other tabs of Source Editor were fine.
I have no idea how to reproduce it.

BBaz

2018-11-04 22:25

reporter   ~0111792

Yes i don't think this is a Sparta designer bug but rather a SynEdit one. And now i even remember that i had seen it too in my D IDE based on synedit, which obviously doesn't use Sparta designer either.

With a bit of luck the fix will address the other, undetermined ways it could happen.

Martin Friebe

2018-11-08 11:38

manager   ~0111858

please test and close if ok

Issue History

Date Modified Username Field Change
2018-11-04 10:58 BBaz New Issue
2018-11-04 12:41 Vojtech Cihak Note Added: 0111779
2018-11-04 22:25 BBaz Note Added: 0111792
2018-11-08 10:52 Martin Friebe Relationship added has duplicate 0034527
2018-11-08 11:31 Martin Friebe Assigned To => Martin Friebe
2018-11-08 11:31 Martin Friebe Status new => assigned
2018-11-08 11:38 Martin Friebe Fixed in Revision => 59490
2018-11-08 11:38 Martin Friebe LazTarget => 2.0
2018-11-08 11:38 Martin Friebe Note Added: 0111858
2018-11-08 11:38 Martin Friebe Status assigned => resolved
2018-11-08 11:38 Martin Friebe Fixed in Version => 2.0
2018-11-08 11:38 Martin Friebe Resolution open => fixed
2018-11-08 11:38 Martin Friebe Target Version => 2.0
2018-11-08 12:05 BBaz Status resolved => closed