View Issue Details

IDProjectCategoryView StatusLast Update
0034515LazarusIDEpublic2019-07-27 16:10
Reporterpiula3Assigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformboth x86/x64OSWindowsOS Version8.1 and 10
Product Version2.0RC2Product Build 
Target VersionFixed in Version 
Summary0034515: inappropriate "create output directory" message on every compile
DescriptionIn my Lazarus installation, I have set the default output directory (target file name) to "Z:\" (i.e. the root of a drive)

This neither used to be a problem in 1.6 nor in 1.8, but the recent 2.0RC2 complains on every compilation with this dialog:

Create directory?
The output directory "Z:\" is missing.
Create it / Cancel

The path Z:\ is available, of course, and clicking "create it" continues the compilation without any problems.
Steps To ReproduceSet "compiler options > target file name" to a name in the root directory of a drive. Start compilation with F9.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0034545 resolvedMattias Gaertner "The output directory "D:\" is missing." on each run if the project is saved to disk root (regression) 

Activities

Bart Broersma

2018-11-25 14:23

developer   ~0112187

Resolving this one, since the other report (0034545) describes where it goes wrong.

piula3

2018-12-28 00:36

reporter   ~0112929

I have tried with RC3 now, but it still doesn't work for me. (Same behavior as RC2.)

Bart Broersma

2018-12-28 09:48

developer   ~0112940

Please continue in 0034545 and close this one.

Martin Friebe

2019-07-27 16:10

manager   ~0117434

From the forum https://forum.lazarus.freepascal.org/index.php/topic,46196.msg328753.html#msg328753

Steps to reproduce:
- New project, empty form
- Save both to d:\temp
- In project options, set target filename to D:\project1.exe
- Compile -> Warning about missing output directory

Issue History

Date Modified Username Field Change
2018-11-06 20:59 piula3 New Issue
2018-11-25 13:01 Juha Manninen Relationship added related to 0034545
2018-11-25 14:23 Bart Broersma LazTarget => -
2018-11-25 14:23 Bart Broersma Note Added: 0112187
2018-11-25 14:23 Bart Broersma Relationship replaced duplicate of 0034545
2018-11-25 14:23 Bart Broersma Status new => resolved
2018-11-25 14:23 Bart Broersma Resolution open => duplicate
2018-11-25 14:23 Bart Broersma Assigned To => Bart Broersma
2018-12-28 00:36 piula3 Note Added: 0112929
2018-12-28 08:07 piula3 Status resolved => assigned
2018-12-28 08:07 piula3 Resolution duplicate => reopened
2018-12-28 09:48 Bart Broersma Note Added: 0112940
2018-12-28 09:48 Bart Broersma Status assigned => resolved
2018-12-28 09:48 Bart Broersma Resolution reopened => duplicate
2018-12-28 17:18 piula3 Status resolved => closed
2019-07-27 16:10 Martin Friebe Note Added: 0117434