View Issue Details

IDProjectCategoryView StatusLast Update
0034524pas2jsrtlpublic2020-02-08 10:35
Reportersilvioprog Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Fixed in Version1.4.0 
Summary0034524: [FEATURE REQUEST] TStream (+ ideias to implement it)
DescriptionHi dudes.

I took a look at pas2js' classes.pas and it seems a TStream was not implemented yet.

What do you think about to implement it using JS buffering? If you agree, I can try it today and send a patch.
TagsNo tags attached.
Fixed in Revision
Attached Files

Activities

Mattias Gaertner

2018-11-07 20:02

developer   ~0111843

Please discuss this on the mailing list.

silvioprog

2018-11-07 23:09

reporter   ~0111850

Done. Sent to the pas2js mailing list! :-)

silvioprog

2018-11-21 07:29

reporter   ~0112092

Hi dudes. Just notifying. I'm working the stream classes at this temporary repository: https://github.com/silvioprog/pas2js_patches .

Today I pushed an initial coding: https://github.com/silvioprog/pas2js_patches/commit/aa0fb2318b2c334b2ca25a6e451babf3e90bbde4 .

I'll send a full patch as soon as it is complete and in a 'stable' version.

Mattias Gaertner

2018-11-21 10:01

developer   ~0112096

Please replace {$IFDEF JAVASCRIPT2015} with {$IF ECMAScript>5}

silvioprog

2018-11-22 01:24

reporter   ~0112106

Done. :-) Now I'm going work in the code for browser (es<=5) ...

silvioprog

2019-07-04 04:36

reporter   ~0117054

Hey dudes, since streams are now available we should close this issue. :-)

Michael Van Canneyt

2020-02-08 10:35

administrator   ~0120935

Implemented since a long time, forgot to set to resolved :(

Issue History

Date Modified Username Field Change
2018-11-07 19:57 silvioprog New Issue
2018-11-07 20:02 Mattias Gaertner Note Added: 0111843
2018-11-07 23:09 silvioprog Note Added: 0111850
2018-11-21 07:29 silvioprog Note Added: 0112092
2018-11-21 10:01 Mattias Gaertner Note Added: 0112096
2018-11-22 01:24 silvioprog Note Added: 0112106
2019-07-04 04:36 silvioprog Note Added: 0117054
2020-02-08 10:35 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-02-08 10:35 Michael Van Canneyt Status new => resolved
2020-02-08 10:35 Michael Van Canneyt Resolution open => fixed
2020-02-08 10:35 Michael Van Canneyt Fixed in Version => 1.4.0
2020-02-08 10:35 Michael Van Canneyt Note Added: 0120935