View Issue Details

IDProjectCategoryView StatusLast Update
0034533FPCTextmode IDEpublic2019-01-02 01:12
ReporterMarģersAssigned ToFlorian 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSlinuxOS Version
Product Version3.3.1Product Build 
Target VersionFixed in Version3.3.1 
Summary0034533: Options -> Save As dialog Save Options has wrong button caption "Open"
DescriptionAdded patch to replace "Open" with "Ok"
TagsNo tags attached.
Fixed in Revision40743
FPCOldBugId
FPCTarget
Attached Files
  • save_as_ok_button.patch (561 bytes)
    Index: packages/ide/fpmopts.inc
    ===================================================================
    --- packages/ide/fpmopts.inc	(revision 40278)
    +++ packages/ide/fpmopts.inc	(working copy)
    @@ -1588,7 +1588,7 @@
         FileName: string;
         CanWrite: boolean;
     begin
    -  New(D, Init('*'+ExtOf(INIFileName),dialog_saveoptions,dialog_ini_filename,fdOpenButton,hidSaveIniFile));
    +  New(D, Init('*'+ExtOf(INIFileName),dialog_saveoptions,dialog_ini_filename,fdOkButton,hidSaveIniFile));
       D^.HelpCtx:=hcSaveAsINI;
       if Desktop^.ExecView(D)<>cmCancel then
         begin
    
  • odok.png (12,535 bytes)
    odok.png (12,535 bytes)
  • save_as_ok_button_v2.patch (1,092 bytes)
    Index: packages/ide/fpide.pas
    ===================================================================
    --- packages/ide/fpide.pas	(revision 40278)
    +++ packages/ide/fpide.pas	(working copy)
    @@ -686,7 +686,7 @@
                     msg_errorsavingconfigfile = 'Error saving config file.';
     
                     {Save options dialog.}
    -                dialog_saveoptions = 'Save Options';
    +                dialog_saveoptions = 'Save Options As';
                     dialog_ini_filename = 'Name of INI file';
     
                     {Window list dialog.}
    Index: packages/ide/fpmopts.inc
    ===================================================================
    --- packages/ide/fpmopts.inc	(revision 40278)
    +++ packages/ide/fpmopts.inc	(working copy)
    @@ -1588,7 +1588,7 @@
         FileName: string;
         CanWrite: boolean;
     begin
    -  New(D, Init('*'+ExtOf(INIFileName),dialog_saveoptions,dialog_ini_filename,fdOpenButton,hidSaveIniFile));
    +  New(D, Init('*'+ExtOf(INIFileName),dialog_saveoptions,dialog_ini_filename,fdOkButton,hidSaveIniFile));
       D^.HelpCtx:=hcSaveAsINI;
       if Desktop^.ExecView(D)<>cmCancel then
         begin
    

Activities

Marģers

2018-11-10 11:58

reporter  

save_as_ok_button.patch (561 bytes)
Index: packages/ide/fpmopts.inc
===================================================================
--- packages/ide/fpmopts.inc	(revision 40278)
+++ packages/ide/fpmopts.inc	(working copy)
@@ -1588,7 +1588,7 @@
     FileName: string;
     CanWrite: boolean;
 begin
-  New(D, Init('*'+ExtOf(INIFileName),dialog_saveoptions,dialog_ini_filename,fdOpenButton,hidSaveIniFile));
+  New(D, Init('*'+ExtOf(INIFileName),dialog_saveoptions,dialog_ini_filename,fdOkButton,hidSaveIniFile));
   D^.HelpCtx:=hcSaveAsINI;
   if Desktop^.ExecView(D)<>cmCancel then
     begin

Thaddy de Koning

2018-11-10 12:41

reporter   ~0111886

I can not reproduce it. See screenshot.

Thaddy de Koning

2018-11-10 12:42

reporter  

odok.png (12,535 bytes)
odok.png (12,535 bytes)

Marģers

2018-11-10 13:17

reporter   ~0111888

Not "Save File As" dialog, but "Save Options" dialog. You definitely can reproduce it, because bug is platform irrelevant.

Steps to reproduce:
1. Open fp
2. Press Alt+o and then A

Thaddy de Koning

2018-11-10 16:36

reporter   ~0111891

Indeed. confirmed. Was not clear to me though.

Bart Broersma

2018-11-10 18:50

reporter   ~0111892

There is no fdSaveButton equivalent?

Marģers

2018-11-10 21:15

reporter   ~0111896

fdSaveButton was my first guess. That does not exist.
It is standart file save dialog and best choice is fdOkButton
TP also use "Ok" button.

Marģers

2018-11-10 21:59

reporter  

save_as_ok_button_v2.patch (1,092 bytes)
Index: packages/ide/fpide.pas
===================================================================
--- packages/ide/fpide.pas	(revision 40278)
+++ packages/ide/fpide.pas	(working copy)
@@ -686,7 +686,7 @@
                 msg_errorsavingconfigfile = 'Error saving config file.';
 
                 {Save options dialog.}
-                dialog_saveoptions = 'Save Options';
+                dialog_saveoptions = 'Save Options As';
                 dialog_ini_filename = 'Name of INI file';
 
                 {Window list dialog.}
Index: packages/ide/fpmopts.inc
===================================================================
--- packages/ide/fpmopts.inc	(revision 40278)
+++ packages/ide/fpmopts.inc	(working copy)
@@ -1588,7 +1588,7 @@
     FileName: string;
     CanWrite: boolean;
 begin
-  New(D, Init('*'+ExtOf(INIFileName),dialog_saveoptions,dialog_ini_filename,fdOpenButton,hidSaveIniFile));
+  New(D, Init('*'+ExtOf(INIFileName),dialog_saveoptions,dialog_ini_filename,fdOkButton,hidSaveIniFile));
   D^.HelpCtx:=hcSaveAsINI;
   if Desktop^.ExecView(D)<>cmCancel then
     begin

Florian

2019-01-02 00:47

administrator   ~0113079

Thanks, applied.

Marģers

2019-01-02 01:12

reporter   ~0113081

Thanks.

Issue History

Date Modified Username Field Change
2018-11-10 11:58 Marģers New Issue
2018-11-10 11:58 Marģers File Added: save_as_ok_button.patch
2018-11-10 12:41 Thaddy de Koning Note Added: 0111886
2018-11-10 12:42 Thaddy de Koning File Added: odok.png
2018-11-10 13:17 Marģers Note Added: 0111888
2018-11-10 16:36 Thaddy de Koning Note Added: 0111891
2018-11-10 18:50 Bart Broersma Note Added: 0111892
2018-11-10 21:15 Marģers Note Added: 0111896
2018-11-10 21:59 Marģers File Added: save_as_ok_button_v2.patch
2019-01-02 00:47 Florian Fixed in Revision => 40743
2019-01-02 00:47 Florian Note Added: 0113079
2019-01-02 00:47 Florian Status new => resolved
2019-01-02 00:47 Florian Fixed in Version => 3.3.1
2019-01-02 00:47 Florian Resolution open => fixed
2019-01-02 00:47 Florian Assigned To => Florian
2019-01-02 01:12 Marģers Note Added: 0113081
2019-01-02 01:12 Marģers Status resolved => closed