View Issue Details

IDProjectCategoryView StatusLast Update
0034545LazarusIDEpublic2019-07-28 10:28
ReportercordylusAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
PlatformOSWindowsOS VersionXP
Product Version2.1 (SVN)Product Buildr59527 
Target Version2.0Fixed in Version 
Summary0034545: "The output directory "D:\" is missing." on each run if the project is saved to disk root (regression)
DescriptionAfter pressing "Create it" it runs successfully. So just an annoyance.

Does not happen on 1.8 and some 1.9 build from approx. half a year ago (I've updated the local repository now and can't say exactly).

This is only relevant if the project is saved to disk root, in a subfolder it doesn't show up.
Steps To ReproduceCreate an empty project and save it to root of the disk. Run.
TagsNo tags attached.
Fixed in Revision59951,59952,61637.
LazTarget2.0
Widgetset
Attached Files

Relationships

has duplicate 0034515 closedBart Broersma inappropriate "create output directory" message on every compile 

Activities

Bart Broersma

2018-11-12 22:49

developer   ~0111944

Last edited: 2018-11-12 23:18

View 2 revisions

This
  if not FileIsInPath(TargetExeDirectory,WorkingDir)
returns false for FileIsInPath('D:\','D:\')
(because (length(ExpFile)>l) fails (l=3))

appr line 6844 in ide/main.pp.

piula3

2018-12-28 17:19

reporter   ~0112954

I have tried RC3 meanwhile and unfortunately this issue is still alive. Same message as with RC2.

Bart Broersma

2018-12-28 18:03

developer   ~0112956

Last edited: 2018-12-28 18:45

View 2 revisions

That's hardly surprising since it wasn't fixed, as you could have seen here...

Can you test if r58032 is still OK?

Bart Broersma

2018-12-30 18:35

developer   ~0113018

Target 2.0 since it's a regression.

Bart Broersma

2018-12-30 19:15

developer   ~0113020

It's caused by r58033.

Martin Friebe

2019-07-27 15:42

manager   ~0117432

See https://forum.lazarus.freepascal.org/index.php/topic,46196.msg328753.html#msg328753
Just tested, still present in trunk, and fixes_2.0

Martin Friebe

2019-07-27 16:10

manager   ~0117433

From the forum
Steps to reproduce:
- New project, empty form
- Save both to d:\temp
- In project options, set target filename to D:\project1.exe
- Compile -> Warning about missing output directory

Maybe should go on the "duplicate issue"?

Issue History

Date Modified Username Field Change
2018-11-12 20:43 cordylus New Issue
2018-11-12 22:30 Bart Broersma LazTarget => -
2018-11-12 22:30 Bart Broersma Status new => confirmed
2018-11-12 22:49 Bart Broersma Note Added: 0111944
2018-11-12 23:18 Bart Broersma Note Edited: 0111944 View Revisions
2018-11-25 13:01 Juha Manninen Relationship added related to 0034515
2018-11-25 14:23 Bart Broersma Relationship replaced has duplicate 0034515
2018-12-28 17:19 piula3 Note Added: 0112954
2018-12-28 18:03 Bart Broersma Note Added: 0112956
2018-12-28 18:45 Bart Broersma Note Edited: 0112956 View Revisions
2018-12-28 18:46 Bart Broersma Status confirmed => feedback
2018-12-30 18:35 Bart Broersma LazTarget - => 2.0
2018-12-30 18:35 Bart Broersma Note Added: 0113018
2018-12-30 18:35 Bart Broersma Target Version => 2.0
2018-12-30 19:15 Bart Broersma Note Added: 0113020
2018-12-30 19:15 Bart Broersma Assigned To => Mattias Gaertner
2018-12-30 19:15 Bart Broersma Status feedback => assigned
2018-12-31 13:43 Mattias Gaertner Fixed in Revision => 59952
2018-12-31 13:43 Mattias Gaertner Status assigned => resolved
2018-12-31 13:43 Mattias Gaertner Resolution open => fixed
2019-02-08 16:13 Martin Friebe Fixed in Revision 59952 => 59951,59952
2019-07-27 15:42 Martin Friebe Status resolved => assigned
2019-07-27 15:42 Martin Friebe Resolution fixed => reopened
2019-07-27 15:42 Martin Friebe Note Added: 0117432
2019-07-27 16:10 Martin Friebe Note Added: 0117433
2019-07-28 10:28 Mattias Gaertner Status assigned => resolved
2019-07-28 10:28 Mattias Gaertner Fixed in Revision 59951,59952 => 59951,59952,61637.