View Issue Details

IDProjectCategoryView StatusLast Update
0034577LazarusLCLpublic2018-11-22 16:36
ReporterDean HartmanAssigned ToMichl 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindows 64OSWindows 10 - Pro 64OS Version1809 (17763.134)
Product Version2.0RC2Product BuildSVN Rev 59373 
Target VersionFixed in Version 
Summary0034577: PageControl corrupts display when TabPosition is tpLeft or tpRight
DescriptionItems (panels for example) not displayed properly when PageControl TabPosition is tpLeft or tpRight. Display is correct when tpTop or tpBottom.
Steps To Reproduce1) Create new application
2) Add Page Control with 2 pages, tabs at tpTop
3) Add 3 Panels to a page, set colors Red, yellow, blue
4) Compile, run -- Display is correct
5) Change PageControl TabPosition to tpRight
6) Compile, run -- Panels are not all displayed correctly
 
Additional InformationSample source attached.
Same source compiled with Laz 1.8 runs properly regardless of TabPosition
TagsNo tags attached.
Fixed in Revision59621
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0033824 closedMichl Tabs of PageControl flickers 

Activities

Dean Hartman

2018-11-20 22:45

reporter  

TestProj.zip (129,405 bytes)

Dean Hartman

2018-11-21 16:49

reporter   ~0112102

Seems to be caused by implementation of CustomTabControlWndProc in win32pagecontrol.inc. (for flickering prevention???)
 
Commenting out line 361: SubClassWndProc := @CustomTabControlWndProc; and recompiling IDE eliminated the tab position problem.

Michl

2018-11-22 08:09

developer   ~0112107

Fixed in trunk revision 59621. Please test and close if ok.

Dean Hartman

2018-11-22 16:36

reporter   ~0112112

The PageControl tpLeft/tpRight issue has been corrected in Revision 59621.

Issue History

Date Modified Username Field Change
2018-11-20 22:45 Dean Hartman New Issue
2018-11-20 22:45 Dean Hartman File Added: TestProj.zip
2018-11-21 16:49 Dean Hartman Note Added: 0112102
2018-11-21 22:00 Martin Friebe Relationship added related to 0033824
2018-11-22 08:03 Michl Assigned To => Michl
2018-11-22 08:03 Michl Status new => assigned
2018-11-22 08:09 Michl Fixed in Revision => 59621
2018-11-22 08:09 Michl LazTarget => -
2018-11-22 08:09 Michl Note Added: 0112107
2018-11-22 08:09 Michl Status assigned => resolved
2018-11-22 08:09 Michl Resolution open => fixed
2018-11-22 16:36 Dean Hartman Note Added: 0112112
2018-11-22 16:36 Dean Hartman Status resolved => closed