View Issue Details

IDProjectCategoryView StatusLast Update
0034601LazarusLCLpublic2020-07-13 20:51
Reporternanobit Assigned ToJesus Reyes  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformwin32OSWindows 
Summary0034601: cairoprinter.pas not compilable with -CR
DescriptionSolution: in cairoprinter.pas:
remove TDocAccess type and its use as typecast.
Nothing else is required, because all elements are public.

Example:
fCairoCanvas.XDPI:=fXDPI; instead of
{%H-}TDocAccess(fCairoCanvas).XDPI:=fXDPI;
TagsNo tags attached.
Fixed in Revisionr60207
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Jesus Reyes

2020-07-13 20:51

developer   ~0123992

TDocAccess was removed so this report should now be fixed

Issue History

Date Modified Username Field Change
2018-11-25 16:16 nanobit New Issue
2020-07-13 20:51 Jesus Reyes Assigned To => Jesus Reyes
2020-07-13 20:51 Jesus Reyes Status new => resolved
2020-07-13 20:51 Jesus Reyes Resolution open => fixed
2020-07-13 20:51 Jesus Reyes Fixed in Revision => r60207
2020-07-13 20:51 Jesus Reyes LazTarget => -
2020-07-13 20:51 Jesus Reyes Widgetset Win32/Win64 => Win32/Win64
2020-07-13 20:51 Jesus Reyes Note Added: 0123992