View Issue Details

IDProjectCategoryView StatusLast Update
0034649LazarusIDEpublic2020-01-21 18:10
ReporterTony WhymanAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinux Mint 18OSLinuxOS Version4.4.0
Product Version2.0RC2Product Build 
Target VersionFixed in Version 
Summary0034649: Source Code Editor shows inverted interpretation of $if statements
DescriptionA simple program:

program Project1;

uses LCLVersion;

begin
  writeln(lcl_fullversion);
  {$if lcl_fullversion < 2000000}
  writeln('lower');
  {$ifend}
  {$if lcl_fullversion > 2000000}
  writeln('upper');
  {$ifend}
end.

In the IDE, "writeln('upper') is greyed out, while when the program runs, "upper" is written out and not lower. i.e. the reverse of what is implied by the greying out.
Steps To ReproduceCompile and go
Additional InformationProbably worth adding a breakpoint on the final "end". When I run the IDE under Linux, the console output is on guaranteed to appear when a breakpoint is set. May be another bug?
TagsNo tags attached.
Fixed in Revision0030109
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0036612 resolvedBart Broersma Codetool parses "{$IF ident > n}" wrong / Lazarus editor grayed out wrong section of const conditional compilation 
related to 0029998 new Wrong color of conditional-compile code 
related to 0030109 confirmed IDE editor: {$if} doesn't evaluate constants 

Activities

Tony Whyman

2018-12-05 11:40

reporter   ~0112367

Typo in the last message. Should read "..the console output is not guaranteed..."

Issue History

Date Modified Username Field Change
2018-12-05 11:38 Tony Whyman New Issue
2018-12-05 11:40 Tony Whyman Note Added: 0112367
2018-12-05 12:26 Martin Friebe Relationship added related to 0029998
2018-12-05 12:27 Martin Friebe Relationship added related to 0030109
2020-01-21 05:29 Martin Friebe Relationship added duplicate of 0036612
2020-01-21 18:10 Bart Broersma Assigned To => Bart Broersma
2020-01-21 18:10 Bart Broersma Status new => resolved
2020-01-21 18:10 Bart Broersma Resolution open => duplicate
2020-01-21 18:10 Bart Broersma Fixed in Revision => 0030109
2020-01-21 18:10 Bart Broersma LazTarget => -
2020-01-21 18:10 Bart Broersma Widgetset GTK 2 => GTK 2