View Issue Details

IDProjectCategoryView StatusLast Update
0034756LazarusLCLpublic2019-05-14 08:36
ReporterCyril LAMYAssigned ToZoran Vučenović 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSOSX MojaveOS Version
Product Version2.0RC2Product Build 
Target VersionFixed in Version 
Summary0034756: TDateTimePicker doesn't work on Cocoa if Kind set to dtkTime
DescriptionOn OSX using cocoa widgetset, if a TDateTimePicker component is put on a form and Kind property set to dtkTime, when you click on an arrow to change the time, the 2 arrows stays blocked on white and the time displayed doesn't change. You can't also enter a time using the keyboard. It seems as if the component is blocked. If you click outside the form (on the desktop), the time change.
Steps To ReproducePut a TDateTimePicker on a form, set Kind to dtkTIme and use cocoa widgetset
 
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Cyril LAMY

2018-12-24 12:35

reporter  

TDatetimePicker.zip (133,522 bytes)

Cyril LAMY

2018-12-24 12:35

reporter  

atstartup.png (19,186 bytes)
atstartup.png (19,186 bytes)

Cyril LAMY

2018-12-24 12:36

reporter  

Cyril LAMY

2018-12-24 12:39

reporter   ~0112858

Attached 2 screenshots. The first is taken at application startup (2 arrows are black).
The second is taken after a the mouse pass over the arrows (without click). The 2 arrows are white and clicking on them doesn't change displayed time.
To change displayed time, you have to click on one arrow and then click outside the main form (on the desktop).

Cyril LAMY

2019-01-01 19:47

reporter   ~0113070

Tested with r59970.
Arrows still remain white since the mouse pass over them but I can now change time by clicking on the arrows as expected.

Zoran Vučenović

2019-01-11 22:49

developer   ~0113340

I don't have Mac, I hope someone who has it will take a look at this problem.

Aschwin van Loon

2019-05-09 12:53

reporter   ~0116099

This is still not fixed in r61164 on Max Osx.
When you put it on a clean new form and you change it to dtkTime you get an access violation.
See attachment.

Schermafbeelding 2019-05-09 om 12.51.15.png (518,253 bytes)

Zoran Vučenović

2019-05-09 22:46

developer   ~0116103

Last edited: 2019-05-09 22:57

View 2 revisions

I can't debug myself, because, as I said already, I do not have Mac, but let's just try to narrow the problem.

Probably it is related to embedded UpDown control.

Just to make sure and help debugging:
Please, create new application, put a DateTimePicker (not DBDateTimePicker, as I don't think this is specific to DB control) on the form and, instead of setting Kind to dtkTime, set DateMode to dmUpDown.
Does the same bug appear?

Assuming that it does, could you try one more thing:
In datetimepicker.pas unit, find the declaration of TDTUpDown class and in all three overriden methods, comment out all code except inherited call. Rebuild the IDE and test if the bug is still there.

Aschwin van Loon

2019-05-10 00:49

reporter   ~0116104

Just to make sure and help debugging:
Please, create new application, put a DateTimePicker (not DBDateTimePicker, as I don't think this is specific to DB control) on the form and, instead of setting Kind to dtkTime, set DateMode to dmUpDown.
Does the same bug appear? -=> YES

Aschwin van Loon

2019-05-10 00:58

reporter   ~0116105

Assuming that it does, could you try one more thing:
In datetimepicker.pas unit, find the declaration of TDTUpDown class and in all three overriden methods, comment out all code except inherited call. Rebuild the IDE and test if the bug is still there.

IT'S STILL THERE

Aschwin van Loon

2019-05-10 00:59

reporter   ~0116106

This is what you meant if I am not mistaken

datetimepicker.pas (108,265 bytes)

Dmitry Boyarintsev

2019-05-10 04:52

developer   ~0116107

Last edited: 2019-05-10 04:53

View 2 revisions

related to 0035531 ?
try Lazarus after r61169

Zoran Vučenović

2019-05-14 08:34

developer   ~0116192

Reported in forum that it is fixed.
I'm resolving it now.

Issue History

Date Modified Username Field Change
2018-12-24 12:35 Cyril LAMY New Issue
2018-12-24 12:35 Cyril LAMY File Added: TDatetimePicker.zip
2018-12-24 12:35 Cyril LAMY File Added: atstartup.png
2018-12-24 12:36 Cyril LAMY File Added: blocked-with-white-arrows.png
2018-12-24 12:39 Cyril LAMY Note Added: 0112858
2019-01-01 19:47 Cyril LAMY Note Added: 0113070
2019-01-11 22:49 Zoran Vučenović Note Added: 0113340
2019-05-09 12:53 Aschwin van Loon File Added: Schermafbeelding 2019-05-09 om 12.51.15.png
2019-05-09 12:53 Aschwin van Loon Note Added: 0116099
2019-05-09 20:41 Zoran Vučenović Note View State: 0116099: private
2019-05-09 20:41 Zoran Vučenović Note View State: 0116099: public
2019-05-09 22:46 Zoran Vučenović Note Added: 0116103
2019-05-09 22:57 Zoran Vučenović Note Edited: 0116103 View Revisions
2019-05-10 00:49 Aschwin van Loon Note Added: 0116104
2019-05-10 00:58 Aschwin van Loon Note Added: 0116105
2019-05-10 00:59 Aschwin van Loon File Added: datetimepicker.pas
2019-05-10 00:59 Aschwin van Loon Note Added: 0116106
2019-05-10 04:52 Dmitry Boyarintsev Note Added: 0116107
2019-05-10 04:53 Dmitry Boyarintsev Note Edited: 0116107 View Revisions
2019-05-14 08:32 Zoran Vučenović Assigned To => Zoran Vučenović
2019-05-14 08:32 Zoran Vučenović Status new => assigned
2019-05-14 08:34 Zoran Vučenović Status assigned => resolved
2019-05-14 08:34 Zoran Vučenović Resolution open => fixed
2019-05-14 08:34 Zoran Vučenović LazTarget => -
2019-05-14 08:34 Zoran Vučenović Widgetset Cocoa => Cocoa
2019-05-14 08:34 Zoran Vučenović Note Added: 0116192