View Issue Details

IDProjectCategoryView StatusLast Update
0034786FPCCompilerpublic2019-01-02 20:42
ReporterAndi FriessAssigned ToFlorian 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformRaspberry Pi 3B+ OSRaspbian OS Version
Product Version3.2.0Product Buildfixes 3.2 
Target VersionFixed in Version3.2.0 
Summary0034786: Fatal: Internal error 200108231 - compiling of Lazarus breaks
Description24) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/data/lazdev/fixes32_20/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4516,20) Hint: (4055) Conversion between ordinals and pointers is not portable
/home/pi/data/lazdev/fixes32_20/lazarus/lcl/interfaces/./gtk2/gtk2proc.inc(4705,15) Fatal: Internal error 200108231
Fatal: (1018) Compilation aborted
Error: /home/pi/data/lazdev/fixes32_20/fpc/bin/arm-linux/ppcarm returned an error exitcode
Error: (lazarus) Compile package LCL 2.0.0.3: stopped with exit code 1
Error: (lazarus) [TLazPackageGraph.CompileRequiredPackages] "Exit code 1"
Error: (lazarus) Building IDE: Compile AutoInstall Packages failed.
Makefile:3370: die Regel für Ziel „useride“ scheiterte
make: *** [useride] Fehler 2
make: Verzeichnis „/home/pi/data/lazdev/fixes32_20/lazarus“ wird verlassen
Steps To Reproducemake Lazarus with useride

Additional Informationmake FPC=/home/pi/data/lazdev/fixes32_20/fpc/bin/arm-linux/fpc.sh PP=/home/pi/data/lazdev/fixes32_20/fpc/bin/arm-linux/ppcarm USESVN2REVISIONINC=0 --directory=. INSTALL_PREFIX=/home/pi/data/lazdev/fixes32_20/lazarus FPCDIR=/home/pi/data/lazdev/fixes32_20/fpcsrc FPCMAKE=/home/pi/data/lazdev/fixes32_20/fpc/bin/arm-linux/fpcmake PPUMOVE=/home/pi/data/lazdev/fixes32_20/fpc/bin/arm-linux/ppumove CFGFILE=/home/pi/data/lazdev/fixes32_20/config_lazarus/idemake.cfg OPT=-vw-n-h-l-d-u-t-p-c- useride
TagsNo tags attached.
Fixed in Revision40740
FPCOldBugId
FPCTarget
Attached Files

Relationships

related to 0034438 resolvedPierre Muller Internal error 

Activities

Andi Friess

2018-12-31 14:47

reporter   ~0113044

see 0034438,0034495 - this was trunk

Looks like the same in actual fixes 3.2

Andi Friess

2018-12-31 20:57

reporter   ~0113050

fixes from trunk svn 40202 works too. Please merge into fixes 3.2 branch.

Andi Friess

2019-01-02 20:42

reporter   ~0113109

Works perfect. No errror anymore. Thanks.

Issue History

Date Modified Username Field Change
2018-12-31 14:44 Andi Friess New Issue
2018-12-31 14:47 Andi Friess Note Added: 0113044
2018-12-31 20:57 Andi Friess Note Added: 0113050
2019-01-01 23:01 Florian Relationship added related to 0034438
2019-01-01 23:01 Florian Fixed in Revision => 40740
2019-01-01 23:01 Florian Status new => resolved
2019-01-01 23:01 Florian Fixed in Version => 3.2.0
2019-01-01 23:01 Florian Resolution open => fixed
2019-01-01 23:01 Florian Assigned To => Florian
2019-01-02 20:42 Andi Friess Note Added: 0113109
2019-01-02 20:42 Andi Friess Status resolved => closed