View Issue Details

IDProjectCategoryView StatusLast Update
0034808FPC[All Projects] Generalpublic2019-02-05 08:46
ReporterPéter GáborAssigned ToJoost van der Sluis 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version3.3.1 
Summary0034808: IDE: FPPKG requires root on Linux (and other *nix systems)
DescriptionThis is (also) an IDE bug at this moment because Lazarus (trunk) uses FPPKG by default (without installing the package itself).

But the main problem is that FPPKG requires root access to write the backup file of its configuration in /etc. This is an old problem, but because I did not use FPPKG it was not annoying for me.

The following message appears (always) when I try to compile something with lazbuild:

> Error: (lazbuild) An error occured during the initialization of Fppkg: %s.
> Check your Fppkg configuration and restart Lazarus to be able to use Fppkg's functionality.
> An error occured during the initialization of Fppkg: Backup of file "/etc/fppkg/default" to file "/etc/fppkg/default.bak" failed..
> Check your Fppkg configuration and restart Lazarus to be able to use Fppkg's functionality.

The following message appears (always) when I start the IDE:

> An error occured during the initialization of Fppkg: Backup of file "/etc/fppkg/default" to file "/etc/fppkg/default.bak" failed..
> Check your Fppkg configuration and restart Lazarus to be able to use Fppkg's functionality.

It seems that FPPKG ignores the "--primaryconfigpath" command line parameter passed to the IDE.
Also I think using fppkg without installing the package in the IDE is a mistake.

(I'm on Linux / XFCE / GTK2)
TagsNo tags attached.
Fixed in Revisionr40711
FPCOldBugId
FPCTarget
Attached Files

Activities

Péter Gábor

2019-01-28 20:23

reporter  

fppkg_bug_34808.png (19,613 bytes)
fppkg_bug_34808.png (19,613 bytes)

Péter Gábor

2019-01-28 20:27

reporter   ~0113702

Screenshot of error message dialog added. It appears after the splash window when the IDE starts.

(caption of the dialog is displayed without replacing %s with the actual error message)

Joost van der Sluis

2019-01-30 22:41

manager   ~0113747

I'm still wondering how you got into this messy configuration.

Péter Gábor

2019-02-02 15:35

reporter   ~0113795

Last edited: 2019-02-02 15:38

View 4 revisions

Reopened just to give some info. Can be marked as resolved again. Thanks!

This issue was started (noticed) some months ago when I was installing FppkgPackageManager component in Lazarus trunk to create/update translations for it.

I have the followings installed on the system (available for all users)
* FPC 3.0.4 from the distro's package repo

I have the followings in my home directory (available for me and noone else)
* FPC trunk in my home directory
* Lazarus fixes version from SVN in my home directory, updated every day (uses FPC 3.0.4, see above)
* FPC trunk version from SVN in my home directory, updated every month or when Lazarus trunk needs it
* Lazarus trunk version from SVN in my home directory, updated every day (uses FPC trunk, see above)

In the past Lazarus was installed on the system from the distro's package repo (available for all users) and later removed.

After your answer I checked the full hdd for "fppkg" and I found some fppkg related configuration files:
* files installed with FPC 3.0.4 (from distro's package repo)
* two additional files (attached)
    /etc/fppkg/default
    /etc/fppkg.cfg

Removing these two files seems to be solving the problem.

After rebuilding the IDE and reinstalling FpkgPackageManager component in the IDE and when I open it from the menu I've got another message: "Fppkg seems to be configured, but the RTL could not be found. Please fix the Fppkg-configuration with the wizard or manualy."
This did not happen never before (as I can remember), so I don't know when the two files (see above) were created.
Maybe when Lazarus was installed on the system from distro's package repo and started as root for a rebuild session or if fpc was rebuilt as root...

Péter Gábor

2019-02-02 15:35

reporter  

default (146 bytes)
[Defaults]
ConfigVersion=4
GlobalPrefix=/usr/lib/fpc/../../
LocalPrefix={LocalRepository}
Compiler=/usr/lib/fpc/../../bin/fpc
OS=Linux
CPU=x86_64
default (146 bytes)

Péter Gábor

2019-02-02 15:36

reporter  

fppkg.cfg (314 bytes)

Joost van der Sluis

2019-02-03 22:45

manager   ~0113842

The wizard is brand new, committed just this weekend.

I hope it can solve most problems. Thanks for the feedback.

Issue History

Date Modified Username Field Change
2019-01-04 09:07 Péter Gábor New Issue
2019-01-04 09:53 Mattias Gaertner Assigned To => Joost van der Sluis
2019-01-04 09:53 Mattias Gaertner Status new => assigned
2019-01-28 20:23 Péter Gábor File Added: fppkg_bug_34808.png
2019-01-28 20:27 Péter Gábor Note Added: 0113702
2019-01-30 22:39 Joost van der Sluis Project Lazarus => FPC
2019-01-30 22:39 Joost van der Sluis Category IDE => General
2019-01-30 22:41 Joost van der Sluis Fixed in Revision => r40711
2019-01-30 22:41 Joost van der Sluis Note Added: 0113747
2019-01-30 22:41 Joost van der Sluis Status assigned => resolved
2019-01-30 22:41 Joost van der Sluis Fixed in Version => 3.3.1
2019-01-30 22:41 Joost van der Sluis Resolution open => fixed
2019-02-02 15:35 Péter Gábor Note Added: 0113795
2019-02-02 15:35 Péter Gábor Status resolved => feedback
2019-02-02 15:35 Péter Gábor Resolution fixed => reopened
2019-02-02 15:35 Péter Gábor File Added: default
2019-02-02 15:36 Péter Gábor File Added: fppkg.cfg
2019-02-02 15:36 Péter Gábor Note Edited: 0113795 View Revisions
2019-02-02 15:38 Péter Gábor Note Edited: 0113795 View Revisions
2019-02-02 15:38 Péter Gábor Note Edited: 0113795 View Revisions
2019-02-03 22:45 Joost van der Sluis Note Added: 0113842
2019-02-03 22:47 Joost van der Sluis Status feedback => resolved
2019-02-03 22:47 Joost van der Sluis Resolution reopened => fixed
2019-02-05 08:46 Péter Gábor Status resolved => closed