View Issue Details

IDProjectCategoryView StatusLast Update
0034816PackagesPackagespublic2019-01-20 11:42
ReporterDmitry Belkevich_2Assigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformwin64OSwindowsOS Version10
Product Version2.1 (SVN)Product BuildSVN version 60001M 
Target VersionFixed in Version 
Summary0034816: The sparta_dockedformeditor could not be compiled and installed
DescriptionInstallation of sparta_dockedformeditor is unsuccessfull in the current trunc version
Steps To ReproduceI have added this package to the list of installed packages in the "Install/Uninitall Packeges" windows:
lazarus\components\sparta\dockedformeditor\sparta_dockedformeditor.lpk
and after pushing the "Save and rebuild IDE" i got this messages:

Compile package sparta_DockedFormEditor 0.0: Exit code 1, Errors: 6
sparta_fakecustom.pas(34,23) Error: No matching implementation for interface method "PositionDelta:<record type>;" found
sparta_fakecustom.pas(34,23) Error: No matching implementation for interface method "SetOnChangeHackedBounds(const TNotifyEvent);" found
sparta_fakecustom.pas(34,23) Error: No matching implementation for interface method "GetOnChangeHackedBounds:<procedure variable type of procedure(TObject) of object;Register>;" found
sparta_fakecustom.pas(34,23) Error: No matching implementation for interface method "PositionDelta:<record type>;" found
sparta_fakecustom.pas(34,23) Error: No matching implementation for interface method "SetOnChangeHackedBounds(const TNotifyEvent);" found
sparta_fakecustom.pas(34,23) Error: No matching implementation for interface method "GetOnChangeHackedBounds:<procedure variable type of procedure(TObject) of object;Register>;" found
TagsNo tags attached.
Fixed in Revisionr60119
LazTarget-
Widgetset
Attached Files
  • spartadock.diff (527 bytes)
    Index: components/sparta/mdi/source/sparta_basicfakecustom.pas
    ===================================================================
    --- components/sparta/mdi/source/sparta_basicfakecustom.pas	(revision 59985)
    +++ components/sparta/mdi/source/sparta_basicfakecustom.pas	(working copy)
    @@ -23,6 +23,7 @@
       private
         FOnChangeHackedBounds: TNotifyEvent;
     
    +  protected
         procedure SetOnChangeHackedBounds(const AValue: TNotifyEvent);
         function GetOnChangeHackedBounds: TNotifyEvent;
         function PositionDelta: TPoint;
    
    spartadock.diff (527 bytes)

Relationships

has duplicate 0034910 resolvedStephano Lazarus [Lazarus] Failing to build sparta packages ( specially sparta_mdi ), due to a faulted sparta_basicfakecustom.pas 

Activities

Andrey Zubarev

2019-01-04 22:36

reporter   ~0113172

I confirm

Michl

2019-01-04 22:41

developer   ~0113173

Here it works (FPC 3.0.4). Do you use FPC trunk? Did you try the build option "clean all"?

Andrey Zubarev

2019-01-04 22:52

reporter   ~0113174

Yes, trunk fpc. Option "clean all" not help

Stephano

2019-01-05 10:09

developer  

spartadock.diff (527 bytes)
Index: components/sparta/mdi/source/sparta_basicfakecustom.pas
===================================================================
--- components/sparta/mdi/source/sparta_basicfakecustom.pas	(revision 59985)
+++ components/sparta/mdi/source/sparta_basicfakecustom.pas	(working copy)
@@ -23,6 +23,7 @@
   private
     FOnChangeHackedBounds: TNotifyEvent;
 
+  protected
     procedure SetOnChangeHackedBounds(const AValue: TNotifyEvent);
     function GetOnChangeHackedBounds: TNotifyEvent;
     function PositionDelta: TPoint;
spartadock.diff (527 bytes)

Stephano

2019-01-05 10:11

developer   ~0113184

Test the attached patch.

Andrey Zubarev

2019-01-05 10:28

reporter   ~0113185

>>Test the attached patch.
Thanks! sparta now works

Dmitry Belkevich_2

2019-01-05 11:03

reporter   ~0113187

I have added implementation code:

procedure TFormImpl.SetOnChangeHackedBounds(const AValue: TNotifyEvent);
begin
  FOnChangeHackedBounds := AValue;
end;

function TFormImpl.GetOnChangeHackedBounds: TNotifyEvent;
begin
  Result := FOnChangeHackedBounds;
end;
                                                                  
After patch and code lazarus have been compiled, thank you

Juha Manninen

2019-01-20 11:42

developer   ~0113516

Fixed, please test.
FPC trunk indeed fixed a bug about visibility from derived classes.

Dmitry Belkevich, the implementation code is there already. No need to add it.

Issue History

Date Modified Username Field Change
2019-01-04 22:31 Dmitry Belkevich_2 New Issue
2019-01-04 22:36 Andrey Zubarev Note Added: 0113172
2019-01-04 22:41 Michl Note Added: 0113173
2019-01-04 22:52 Andrey Zubarev Note Added: 0113174
2019-01-05 10:09 Stephano File Added: spartadock.diff
2019-01-05 10:11 Stephano Note Added: 0113184
2019-01-05 10:28 Andrey Zubarev Note Added: 0113185
2019-01-05 11:03 Dmitry Belkevich_2 Note Added: 0113187
2019-01-20 09:51 Stephano Relationship added has duplicate 0034910
2019-01-20 11:33 Juha Manninen Assigned To => Juha Manninen
2019-01-20 11:33 Juha Manninen Status new => assigned
2019-01-20 11:42 Juha Manninen Fixed in Revision => r60119
2019-01-20 11:42 Juha Manninen LazTarget => -
2019-01-20 11:42 Juha Manninen Note Added: 0113516
2019-01-20 11:42 Juha Manninen Status assigned => resolved
2019-01-20 11:42 Juha Manninen Resolution open => fixed