View Issue Details

IDProjectCategoryView StatusLast Update
0034823FPCLCLpublic2019-02-24 15:45
ReporterKarl-Michael SchindlerAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformpowerpc, i386, x86_64OSMac OS XOS Version10.4-10.6
Product VersionProduct Buildsvn revision 59992 
Target VersionFixed in Version 
Summary0034823: revision 59992 breaks crossbuilding win32 lcl on macOS.
Description2.0-fixes revision 59992 breaks crossbuilding win32 lcl on macOS with this error:

...
ppc386 -Twin32 -Pi386 -XPi386-win32- -Xr -gl -Sc -Fu../../units/i386-win32 -Fu../../../packager/units/i386-win32 -Fu../../../components/lazutils/lib/i386-win32 -Fu.. -Fu. -FE. -FU../../units/i386-win32/win32 -di386 ../lcl.pas
Warning: Option "-Xr" is ignored for the current target platform.
Free Pascal Compiler version 3.0.4 [2018/12/11] for i386
Copyright (c) 1993-2017 by Florian Klaempfl and others
Target OS: Win32 for i386
Compiling ../lcl.pas
Compiling win32int.pp
win32int.pp(21,26) Warning: User defined: Fix implicit pointer conversions
win32wsmenus.pp(253,1) Fatal: Internal error 200611031
Fatal: Compilation aborted
make[3]: *** [Makefile:2706: ../lcl.ppu] Fehler 1
Steps To Reproducesvn up -r 59992
make lcl LCL_PLATFORM=win32 OS_TARGET=win32 PP=ppc386 CPU_TARGET=i386

or

make lcl LCL_PLATFORM=win32 OS_TARGET=win64 PP=ppcx64 CPU_TARGET=x86_64
Additional InformationOS is macOS 10.14. fpc is 3.0.4. The same happens with win64, whereas carbon, cocoa, wince are built successfully.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0032352 new Compiling DoubleCommander project sometimes gives "Fatal: Internal error 200611031" message. 

Activities

Bart Broersma

2019-01-06 17:14

reporter   ~0113210

Please, especially in the case of Internal Errors, search the bugtracker first (searching for the number will find 0032352).
Please close.

Issue History

Date Modified Username Field Change
2019-01-06 14:00 Karl-Michael Schindler New Issue
2019-01-06 17:14 Bart Broersma LazTarget => -
2019-01-06 17:14 Bart Broersma Note Added: 0113210
2019-01-06 17:14 Bart Broersma Relationship added duplicate of 0032352
2019-01-06 17:14 Bart Broersma Status new => resolved
2019-01-06 17:14 Bart Broersma Resolution open => fixed
2019-01-06 17:14 Bart Broersma Assigned To => Bart Broersma
2019-01-06 17:14 Bart Broersma Project Lazarus => FPC
2019-02-24 15:45 Karl-Michael Schindler Status resolved => closed