View Issue Details

IDProjectCategoryView StatusLast Update
0034843FPC[All Projects] Generalpublic2019-02-18 17:28
ReporterAlexey Tor.Assigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformmacOS 10.8OSOS Version
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0034843: Cannot build macOS IDE, FPC internal error
DescriptionCompiling ./widgetset/wsforms.pp
Assembling (pipe) units/i386-darwin/wsforms.s
customform.inc(717,3) Note: Local variable "NewState" not used
Assembling (pipe) units/i386-darwin/forms.s
controls.pp(3099,3) Note: Local variable "LastFrm" is assigned but never used
Assembling (pipe) units/i386-darwin/controls.s
Compiling menus.pp
menus.pp(177,15) Note: Virtual method "SetName(const AnsiString);" has a lower visibility (private) than parent class TComponent (protected)
Assembling (pipe) units/i386-darwin/menus.s
Compiling imglist.pp
controls.pp(473,1) Fatal: Internal error 200611031
Fatal: Compilation aborted
make[1]: *** [alllclunits.ppu] Error 1
make: *** [lazbuild] Error 2
users-Mac:~ user$
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0032352 new Compiling DoubleCommander project sometimes gives "Fatal: Internal error 200611031" message. 

Activities

Alexey Tor.

2019-01-09 18:45

reporter   ~0113290

FPC 3.0.2 (here 3.0.4 cannot work, so not used)

Alexey Tor.

2019-01-09 18:52

reporter   ~0113291

From inside the ide, IDE was rebuilt OK. hmm.

Bart Broersma

2019-01-09 22:58

reporter   ~0113293

@Alex: please search the bugtrackr before posting bugs, especially internal errors. A search for 200611031 would have found 0032352.
Note: internal errors are always a compiler error and belong to fpc, not Lazarus.

Issue History

Date Modified Username Field Change
2019-01-09 18:44 Alexey Tor. New Issue
2019-01-09 18:45 Alexey Tor. Note Added: 0113290
2019-01-09 18:52 Alexey Tor. Note Added: 0113291
2019-01-09 22:58 Bart Broersma LazTarget => -
2019-01-09 22:58 Bart Broersma Note Added: 0113293
2019-01-09 22:58 Bart Broersma Relationship added duplicate of 0032352
2019-01-09 22:58 Bart Broersma Status new => resolved
2019-01-09 22:58 Bart Broersma Resolution open => duplicate
2019-01-09 22:58 Bart Broersma Assigned To => Bart Broersma
2019-01-09 22:58 Bart Broersma Project Lazarus => FPC
2019-01-09 22:58 Bart Broersma Category IDE => General
2019-02-18 17:28 Alexey Tor. Status resolved => closed