View Issue Details

IDProjectCategoryView StatusLast Update
0034844LazarusDebuggerpublic2019-01-10 14:25
ReporterPascal RiekenbergAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSWindows 10 x64OS Version1803
Product Version2.1 (SVN)Product Build60049 
Target Version2.0Fixed in Version2.0 
Summary0034844: 60049 breaks build of at least i386
Description(3104) Compiling C:\freepascal\laz\debugger\registersdlg.pp
C:\freepascal\laz\debugger\registersdlg.pp(85,31) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(82,34) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(84,35) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(83,39) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(81,33) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(87,37) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(87,76) Hint: (5024) Parameter "Selected" not used
C:\freepascal\laz\debugger\registersdlg.pp(88,39) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(400,19) Error: (5038) Identifier idents no member "Debugger"
C:\freepascal\laz\debugger\registersdlg.pp(400,53) Error: (5038) Identifier idents no member "Debugger"
registersdlg.pp(508) Fatal: (10026) There were 2 errors compiling module, stopping
Fatal: (1018) Compilation aborted
TagsNo tags attached.
Fixed in Revision60050
LazTarget2.0
WidgetsetWin32/Win64
Attached Files

Activities

Martin Friebe

2019-01-10 12:02

manager   ~0113299

fixed in 60050

Pascal Riekenberg

2019-01-10 12:27

reporter   ~0113300

No, it's not:

(3104) Compiling C:\freepascal\laz\debugger\registersdlg.pp
C:\freepascal\laz\debugger\registersdlg.pp(85,31) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(82,34) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(84,35) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(83,39) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(81,33) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(87,37) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(87,76) Hint: (5024) Parameter "Selected" not used
C:\freepascal\laz\debugger\registersdlg.pp(88,39) Hint: (5024) Parameter "Sender" not used
C:\freepascal\laz\debugger\registersdlg.pp(400,19) Error: (5038) Identifier idents no member "Debugger"
registersdlg.pp(508) Fatal: (10026) There were 1 errors compiling module, stopping
Fatal: (1018) Compilation aborted

wp

2019-01-10 12:29

developer   ~0113301

Last edited: 2019-01-10 12:42

View 2 revisions

> fixed in 60050

Really? 60050 is not working for me either (Win10/64 bit, fpc 3.0.4/32 bit): 'registersdlg.pp(400,19) Error: identifier idents no member "Debugger"'

Martin Friebe

2019-01-10 13:31

manager   ~0113303

r60052

... Sorry the problem is that it does not reproduce with my default settings. (various defines passed to the compiler)

I tried to disable them all, and tested again. This time it *should* be fixed.

wp

2019-01-10 13:55

developer   ~0113304

Yes, it compiles again. Thank you.

Issue History

Date Modified Username Field Change
2019-01-10 06:25 Pascal Riekenberg New Issue
2019-01-10 06:25 Pascal Riekenberg Status new => assigned
2019-01-10 06:25 Pascal Riekenberg Assigned To => Martin Friebe
2019-01-10 12:02 Martin Friebe Fixed in Revision => 60050
2019-01-10 12:02 Martin Friebe LazTarget => 2.0
2019-01-10 12:02 Martin Friebe Note Added: 0113299
2019-01-10 12:02 Martin Friebe Status assigned => resolved
2019-01-10 12:02 Martin Friebe Fixed in Version => 2.0
2019-01-10 12:02 Martin Friebe Resolution open => fixed
2019-01-10 12:02 Martin Friebe Target Version => 2.0
2019-01-10 12:27 Pascal Riekenberg Note Added: 0113300
2019-01-10 12:28 Pascal Riekenberg Status resolved => assigned
2019-01-10 12:28 Pascal Riekenberg Resolution fixed => reopened
2019-01-10 12:29 wp Note Added: 0113301
2019-01-10 12:42 wp Note Edited: 0113301 View Revisions
2019-01-10 13:31 Martin Friebe Note Added: 0113303
2019-01-10 13:31 Martin Friebe Status assigned => resolved
2019-01-10 13:31 Martin Friebe Resolution reopened => fixed
2019-01-10 13:55 wp Note Added: 0113304
2019-01-10 14:25 Pascal Riekenberg Status resolved => closed